Search Query not being overwritten

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Search Query not being overwritten

This topic contains 3 replies, has 2 voices, and was last updated by

 
Keymaster
1 year ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #30940

    Participant

    Hi there,

    We are using your awesome plug-in and today figured out there is an override option for the search results page query.
    However in our case, it does not work. Could you see if we are doing anything wrong?

    There are a few attachments showing the issue (the setting which is enabled, the search result inside the search bar when searching for ‘weer’ (weather) and the search results on the search page for that same query (which should be the same as the results in the search bar) and I also populated an admin credential for you, keep in mind we are using the Admin Menu Editor plug-in so navigating might be difficult, try using direct URL’s if you can’t find anything in the admin menu or navigate to Settings/Instellingen > Menu Editor to retrieve the direct URL’s.

    Direct URL to your plugin’s settings: https://texelinformatie.nl/wp-admin/admin.php?page=asp_settings

    To explain a bit the structure: the website is built with Elementor page builder, expanded with multiple PHP functions but for the search results page there is just a default page styled with Elementor, using WordPress’ default query – no adjusments or whatsoever.

    Ofcourse I tried disabling all plug-in’s (except Elementor’s) but that did not help. Disabling Elementor will break the website so I can’t test it anymore but it might still have to do something with it, not sure though.

    Thank you in advance
    Chloë van den Eeden

    Attachments:
    You must be logged in to view attached files.
    #30947

    Hi!

    Thank you for the details. I tried to log-in and check the configuration, but the accound does not seem to have privileges to open the plugin settings.

    From looking at the front-end, I think the search override feature is not enabled. Make sure to turn it on, that may resolve the issue.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #30949

    Participant

    Hi there,

    Thanks for your reply.
    I checked the setting; it indeed was not checked – I thought that the setting (in my screenshot) was the one I needed, but you are correct – it works now!

    Thanks for your quick support.
    Keep up the good work!

    #30954
    You cannot access this content. Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.