Search Result not relevent

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Search Result not relevent

This topic contains 14 replies, has 2 voices, and was last updated by

 
Participant
2 years, 9 months ago.

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #22348

    Participant

    Hi Team,

    Above mentioned is my test server.

    Everything works fine for me except one condition.

    The search give me weird result if I select a topic (its default wp category) or certification (custom taxonomy) without entering any keyword.

    For example: if select “Administration & Secretarial” with out entering keyword and press search button it gives me a result not relevant to “Administration & Secretarial” . Can you please help to fix this.

    Thank you

    #22349

    Participant

    screenshot

    Attachments:
    You must be logged in to view attached files.
    #22365

    Hi,

    Thank you very much for the details. I have found the issue and corrected it.
    The problem was caused by an incorrect search override in conflict with the Elementor page builder. I have made a correction on the plugin code via the plugin editor, now the filters should have effect.
    I will make sure to include this fix in the next upcoming release.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #22367

    Participant

    Hi Ernest,

    Can you guide me how to make this change. I have to update the same on my Live server.

    Thank you

    #22368

    Hi,

    The change was made on the wp-content/plugins/ajax-search-pro/includes/classes/filters/class-asp-searchoverride.php file, but you can copy over the whole wp-content/plugins/ajax-search-pro/ plugin directory to your live server if you want to.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #22369

    Participant

    Hi Ernest,

    I am afraid. Can you please do it for me.

    URL: http://diss.com.qa/

    You can use the same login details of test server

    Thanks in advance.

    • This reply was modified 2 years, 9 months ago by  midhunbaby.
    #22370

    Sure, I have made the change, it should be live now.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #22372

    Participant

    That was quick.

    Great support.

    #22393

    Participant

    Dear Ernest,

    The pages stopped displaying posts after the update yesterday. Could you please check.

    The page only display posts if I deactivate ajax search pro plugin.

    Can you please check. This is very urgent.

    Thank you

    • This reply was modified 2 years, 9 months ago by  midhunbaby.
    Attachments:
    You must be logged in to view attached files.
    #22400

    Hi,

    Indeed, that fix was not correct. I have made a different solution on both servers. Can you please check and confirm if it’s okay?

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #22402

    Participant

    Yes…it worked. Hope there wont be any issue. Client badly shouted at me.

    Can I confirm the client?

    Thank you

    #22403

    I hope too. Let me know if you find anything with it. I think you can confirm this to your client.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #22405

    Participant

    There is any error on test server

    Screenshot attched

    Attachments:
    You must be logged in to view attached files.
    #22407

    Hi,

    It was only the debug information. Can you please refresh to see if it is gone now? It might have been only cached for a few minutes.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #22408

    Participant

    ok..thank you

Viewing 15 posts - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.