Search Result Overlays

This topic contains 18 replies, has 2 voices, and was last updated by gaffer gaffer 1 month, 2 weeks ago.

Viewing 15 posts - 1 through 15 (of 19 total)
  • Author
    Posts
  • #47078
    gaffer
    gaffer
    Participant

    I have this overlay of test results that shows both WordPress and Ajax Search Pro (see image). Nothing in the logs that I can see. Invariably a setting but I can’t find it.

    Thoughts before we resort to login details etc.

    Attachments:
    You must be logged in to view attached files.
    #47084
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi,

    Thanks for the details!

    My guess is that the auto populate is enabled, can you please check it here: https://i.imgur.com/lvhbI9I.png
    Make sure to turn it off, it will prevent auto-triggering the search.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #47105
    gaffer
    gaffer
    Participant

    Ernest
    That did not work. If I turn it to Disabled I get the WordPress search result and not the vertical result I am looking for. If I have it Enabled the vertical results overlay the WordPress result for the same search.

    Currently, I also have it set to twice daily indexing using the Media Service. I find that I could, but now can’t have the search results containing PDF data. But the items indexed would indicate the files have been indexed, but not coming through in the results panel.

    Thoughts, or is it time for you to delve in via admin?
    Lance

    #47115
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi Lance,

    That did not work. If I turn it to Disabled I get the WordPress search result and not the vertical result I am looking for. If I have it Enabled the vertical results overlay the WordPress result for the same search.
    Okay, wait, you want it to replace the original WordPress results somehow? I don’t think that is possible, the results page will still show the original search results.
    You could try a hacky way to maybe hide the results via custom CSS, that could work:

    .search.search-results #content-masonry {
       display: none;
    }

    About the PDF content, the most likely cause is that the index table may not be enabled on the search instance, make sure to check that first.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #47148
    gaffer
    gaffer
    Participant

    Ernest
    I dropped the search widget in the footer and used a link button in the footer taking visitors to the search page I created . That overcame all my issues.

    Thanks

    #47149
    gaffer
    gaffer
    Participant

    This did not go well.

    The results were not displayed using the CSS change but the next pages boxes did appear with no results.

    So, with the CSS change not used, if I type in the search term on the search page and hit Enter, the results will come back in a WordPress form. But if I type the search term and don’t hit Enter the Ajax vertical (intended) result is returned.

    I feel many of my customers will hit Enter which is not the outcome I want as it looks terrible.

    So the CSS change is not appropriate and hitting enter turns up the wrong result (see image)

    Attachments:
    You must be logged in to view attached files.
    #47156
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    You can control what should happen when the user hits enter or clicks the magnifier icon – you can even turn off the redirection if you want to.
    I’m not exactly sure how you want it to setup, but this should definitely help a bit.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #48002
    gaffer
    gaffer
    Participant

    Ernest
    Implemented on the https://cla.asn.au site but on opening the search page/widget receive a message:
    “The request failed. Please check your connection! Status: 500”

    But if you push on and enter a search term all works. Images attached.

    Also, the Indexing of media files set up for Media Services shows no usage but there are hundreds of PDFs that do appear in the search results.

    Thoughts

    Attachments:
    You must be logged in to view attached files.
    #48006
    gaffer
    gaffer
    Participant

    Fixed the 500 error. Turned off Layout options > Search Box Layout > Auto populate

    #48009
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    I was probably an argument which may have triggered the error. If you want me to investigate it further, then you can adde temporary sFTP and back-end details, and I will check it out.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #48045
    gaffer
    gaffer
    Participant
    You cannot access this content.
    #48061
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Looks like it originates to the comments search. Can you turn off this feature: https://i.imgur.com/gEBXCPV.png
    Let me know if it changes anything, it should isolate the issue.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #48065
    gaffer
    gaffer
    Participant

    Ernest
    I am becoming a pain but the 500 error referred to above is back. So I did not solve it. Thoughts.

    #48067
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Okay, I will try to debug this manually.

    I tried to log-in with the details, but it says wrong password. Can you please check?

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #48070
    gaffer
    gaffer
    Participant

    Ernest
    Sorry for that. WordPress allowed me to click save then rejected the password.

    Try
    J#rYGABm@E*ar5

Viewing 15 posts - 1 through 15 (of 19 total)

You must be logged in to reply to this topic.