Search Result page conflict

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Search Result page conflict

This topic contains 4 replies, has 2 voices, and was last updated by sonnenfluse sonnenfluse 1 week, 5 days ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #41084
    sonnenfluse
    sonnenfluse
    Participant

    Hello,

    we have 2 problem we cannot solve on search result page on our own.

    1) On discovernauts.com the search in the header works fine. (just try Jamaica) https://i.imgur.com/wbGpUOy.png But as soon as you hit enter or click on magnifier icon: https://www.discovernauts.com/en/?s=Jamaica or like this: https://www.discovernauts.com/en/?s=Jamaica&asp_active=1&p_asid=4&p_asp_data=1&customset%5B%5D=post&asp_gen%5B%5D=title&filters_initial=1&filters_changed=0&wpml_lang=en&qtranslate_lang=0&woo_currency=USD&current_page_id=44 it shows you results not related at all with the seach query.”

    2) When you overwrite the query in search field: https://imgur.com/lVHZYh5 there are 2 new problems. You cannot hit enter / click search magnifier. And the results with pure ajax are showing just 1 result and already then load more button and in different design then all other results (we defined that design)

    Thanks a lot for helping on this issue.

    Best regards
    Tom

    #41094
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi,

    1. You are probably using the wrong Elementor widtet on the results page. Try switching to the Posts Archive, the regular Posts widget does not support results page queries within the loop.

    2. It might be a conflict with the more results button – can you please try switching to a pagination on the elementor widget to see if that changes anything?

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #41107
    sonnenfluse
    sonnenfluse
    Participant

    Hi Ernest,

    thank you for the hint. We switched to Post archive and this works now at least when you open the page like this:
    https://www.discovernauts.com/en/?s=jamaica or this https://www.discovernauts.com/en/?s=cuba

    We have 2 problems we still cannot solve:

    1) Search form on it will still not work properly. (cannot hit enter or click on search icon) We have put above the existing Posts widget separate by a bottom border.
    2) We are using Ezoic as partner for ads. Once we activate the ads the search in the header will stop working. Any idea how we can solve this? Please note that 1) also exists when Ezoic ads are disabled. So there is no connection between 2) and 1)

    Thank you and best regards
    Tom

    #41109
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi Tom,

    It checked the page, and both of the widgets were still present, so I only removed the plugin class name from the posts widget, so it does not override, and only takes the archive widget into consideration. You should probably remove the old posts widget, I guess you don’t want that there anymore, I did not want to remove it, just in case you need it.

    I also changed the pagination feature to numberic, and that seems to have solved the issue.

    One thing I noticed, that when I am not logged in, there are many many errors on the console log, which affect the overall page load events and terminates the script execution. That is very likely the cause of the malfunctioning search bar. Make sure investigate all the errors and fix them one by one, that will resolve the issue with any non-responding feature.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #41117
    sonnenfluse
    sonnenfluse
    Participant

    Hi Ernest,

    thank you for the swift response and your help much appreciated. Indeed we are testing other stuff too. Currently Ezoic Ad network is deleting variables which is causing issues. We will deactivate it temporarily to finish all around the search.

    Thank you
    Tom

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.