Search results order and prioritization doesn't work

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Search results order and prioritization doesn't work

This topic contains 12 replies, has 2 voices, and was last updated by szieda75 szieda75 1 year, 9 months ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #29831
    szieda75
    szieda75
    Participant

    Dear team,

    we are having issues with having the right pages prioritized in search results. Setting up a priorities rule doesn’t seem to be changing the order of the search results at all. Nor does it work with applying relevant tags. Nor does the ordering by post type. Basically no changes when I play with either of the things listed above. Can you please advise what the cause of the issue could be?

    Thank you.

    Best,
    Stella

    #29835
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi Stella,

    Can I look at this somewhere via the back-end? I run a few tests on our local test environment and it works all right on our end. Thank you!

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #29862
    szieda75
    szieda75
    Participant

    Hey Ernest,

    I don’t think I can give you access to the back-end as the search is installed for an internally used platform in our company. Maybe we could schedule a video call and I can share my screen during the call?

    Thank you.

    Best,
    Stella

    #29870
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi Stella,

    Unfortunately I cannot do that. If you have/will have an online test envirnoment, let me know, and I will check it as soon as possible.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #30016
    szieda75
    szieda75
    Participant

    Hey Ernest, that’s unfortunately, also not possible. While I was looking into the issue, I made adjustments to multiple settings to see what’s working and what is not. What I noticed – the adjustments are not working only for the main search bar (we have multiple other, smaller search bars). Do you have any idea why it could be happening or where can I look for answers?

    Thank you.

    Stella

    #30021
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi Stella,

    Well, let’s then try the export/import first, maybe I can see something on the search instance settings that might be off. Can you please go to the export/import panel, and export all the search instances: https://i.imgur.com/QkylV27.png
    Then please copy the exported text to a .txt file and upload it here. I will download and try to import them on a fresh installation.

    Please let me know which search bar (name) does not work, and which is okay. I will then try to spot the differences.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #30035
    szieda75
    szieda75
    Participant

    Hey Ernest,

    thank you. I have attached the text file. The one that doesn’t work is called “Main”.

    Best,
    Stella

    Attachments:
    You must be logged in to view attached files.
    #30043
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Thank you! I think I see the problem. The post type group ordering seems to be enabled, while it is off on the other search bars. Please try turning it off here: https://i.imgur.com/30XYK0w.png

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #30050
    szieda75
    szieda75
    Participant

    Hey Ernest, yes, I did that but the search results don’t change. It’s like no matter what changes I apply, the results remain always the same.

    Thank you.

    Best,
    Stella

    #30069
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    The only other difference I can spot is the grouping featue – which is enabled on the Main search, but not on the other ones (I checked a few). Please try turning that off as well: https://i.imgur.com/lqY2fs0.png

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #30125
    szieda75
    szieda75
    Participant

    Hey Ernest,

    yes, I tried to switch off grouping as well but again – absolutely no difference in the order of the search results.

    Thank you.

    Best,
    Stella

    #30127
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    One last thing comes to my mind. Are we talking about the results page here, or the live results below the search bar (when typing)?
    Because I’m not sure if the results page override feature is active, in case this relates to the results page. Make sure to turn it on.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #30218
    szieda75
    szieda75
    Participant

    Hey Ernest,

    yes, indeed, I think that must have been it! The override feature was not activated. Once I did it, I saw changes in search results.

    Thank you!

    Best,
    Stella

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.