Search results page not loading

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Search results page not loading

This topic contains 1 reply, has 2 voices, and was last updated by

 
Keymaster
3 years ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #20764

    Participant

    I use PolyLang for a multilingual website. When I configure Ajax Search Pro to “Redirect to: Results page” when pressing the return button (Override the default WordPress search results OFF), I get a 404 on the french version of the website and it redirects to the homepage in english.

    In french
    http://shorfishing.steveforest.com/fr/accueil/?s=test
    In english
    http://shorfishing.steveforest.com/en/home/?s=test

    I figured out that the “/accueil/” and “/home/” is the problem in the URLs. Without it, the search results page loads. How can I configure Ajax Search Pro to load “/fr/?s=test” and “/en/?s=test” to make it works? Is using custom URLs by adding a function in functions.php the only way? I’m not a programmer so i’d like to know if there’s another way.

    Thanks

    #20773

    Hi!

    The Home URL is requested via the polylang API pll_home_url() function, and it should always return the site root home URL, which should be then the absolute point to the search queries.
    That cannot be changed within the plugin, as it is a core set URL. Can you please check if your site URL and the WordPress address are set correctly to ‘http://shorfishing.steveforest.com’ on the WordPress Settings -> General panel. Polylang may also have some other URL related options, I am not sure, but I recommend checking those as well.
    You can also make sure to force the correct site and home URLs, by changing them in the wp-config.php file.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.