Search results showing only in main language.

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Search results showing only in main language.

This topic contains 6 replies, has 2 voices, and was last updated by ivans ivans 7 years, 2 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #4919
    ivans
    ivans
    Participant

    I’m using Ajax Search Pro in a WordPress with WMPL.
    The problem is: search only gets results from main (default) language even I’m in another language.
    Desired function: search to get results in each language.
    Example: if I’m in /FR get post translanted in FR, etc.

    • This topic was modified 7 years, 2 months ago by ivans ivans.
    #4927
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    That’s how it should work by default. Was it working before or it didn’t work at all?
    What type of content are you searching? (posts, pages, custom post types etc..?)

    Can you provide temporary ftp and admin access to check on this issue? I have no other reports of WPML issues, so I don’t know what could it be.

    There is one known bug with the current version which affects a small percent of installations, but I don’t know if it could cause this. To make sure that bug is not present, please open up the Fulltext search options and save the settings without changing anything. Please let me know if it affects the problem in any ways.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #4930
    ivans
    ivans
    Participant

    Hi,

    Thanks for your quick answer.
    I’ve saved Fulltext search options and issue is still happening.

    Since the plugin description says is WPML compatible, I expected to get results from current language. If search is made in EN get EN resultats, If search is made in ES get ES results.

    I’m searching in custom post types only.

    How can I edit Private Details in this post in order to send you ftp details safely?

    #4931
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    You can include private details safely by editing your first post in this thread and filling out the proper form, or by uploading a txt file with the details. Both methods are safe and only visible for you (topic owner) and me (administrator).

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #4933
    ivans
    ivans
    Participant

    Great. Please find new information in Private Details.
    Feel free to modify anything. I have a copy and it’s a testing site.
    Thanks

    #4944
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    The problem was, that the custom ajax handler was enabled. WPML is bound to load with specific back-end events (in some cases), and the custom ajax handler bypasses some of them, to achieve somewhat better performance. I’ve disabled it on the Compatibility settings panel, now the results will appear with the correct language.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #4945
    ivans
    ivans
    Participant

    Works perfect!
    Thanks for your quick answer.
    Excellent plugin by the way!

    Cheers
    Iván

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.