Search Settings shortcode not working & how to show only filters that have resul

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Search Settings shortcode not working & how to show only filters that have resul

This topic contains 10 replies, has 2 voices, and was last updated by Ernest Marcinko Ernest Marcinko 2 years, 9 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #24885
    ssoulless45
    ssoulless45
    Participant

    I have set up all the settings I need to display search settings on the sidebar of the results page of search so my users can filter products.

    Im using the shortcode the plugin indicates I can use to display the search settings however it is not working, the search settings keep showing as a toggle button in the search bar as you can see on the screenshots the settings are correct (I think so) but the search filters keep showing up as a toggle button below the search bar!

    Also I see that all the filter options show up! I would like to know if there’s a way to only show the filters that have counts, I mean, I want to show a filter option only if there are products in it instead of displaying a full list of filters even when they have no results in it for current search query.

    Thanks in advance.

    Attachments:
    You must be logged in to view attached files.
    #24890
    ssoulless45
    ssoulless45
    Participant

    Here’s the image where I have the settings check the screenshot

    Attachments:
    You must be logged in to view attached files.
    #24899
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    Thank you for all the details, it helps us a lot. I tried to log-in to the back-end, but there is something wrong, as it does not let me open the admin page: https://i.imgur.com/vLER3EZ.png

    Okay, I think the problem here is, that the “HTML widget” does not support shortcodes in WordPress. Please try the “Text Widget Shortcode”, that should support shortcodes properly. Also, the <center> HTML tag is obsolete, it will have no effect on most browsers unfortunately, I would not recommend using it.

    If you want to turn off the settings swtich, you can do that here: https://i.imgur.com/FcdIJnG.png

    Unfortunately at the moment dynamically updating filters are not supported, only all of the filters can be displayed.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #24903
    ssoulless45
    ssoulless45
    Participant

    Ok thanks for answering, I just want you to check the settings I have, because I have tried everything even the “Text Widget shortcode” you mention and still I can manage to make it appear on the sidebar of my marketplace.

    Are you accessing from an old chrome browser? that error occurs for an issue with the SSL on old browsers, please try using another browser.

    #24911
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi,

    I am using the latest chrome release. I also tried firefox, edge, but the same issue. The error message is ERR_TOO_MANY_REDIRECTS, which usually happens when there is an issue with the mod_rewrite rules in the .htaccess file.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #24920
    ssoulless45
    ssoulless45
    Participant

    Could you ask a colleague and check if the issue persists? I have 5 laptops in my office and I can access the website with all of them, very weird.

    #24921
    Ernest Marcinko
    Ernest Marcinko
    Keymaster
    You cannot access this content. Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #24922
    ssoulless45
    ssoulless45
    Participant
    #24923
    Ernest Marcinko
    Ernest Marcinko
    Keymaster
    You cannot access this content. Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #24990
    ssoulless45
    ssoulless45
    Participant

    Ok if you can’t access I will send you my settings I have the text widget on the sidebar of my website, and I also attach the config of the search settings. The shortcode is not working at all, I have tried html widget as well with no results, when I turn on the option “Show search settings switch on the frontend?” the switch button is shown on the search bar, and with I turn on the option “Set the search settings to visible by default” then the options are shown below the search bar and not in the sidebar of my website…

    By the way very weird you can’t access the website, I have admins on many countries you’re the only one that can’t access.

    Attachments:
    You must be logged in to view attached files.
    #25000
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    I honestly don’t know why I cannot access, but since even using a bypass proxy returns the same error, the issue does not seem to be on our end unfortunately.

    Okay, let’s try different settings then. Instead of using the settings shortcode, please try this variation:
    1. Turn off the search bar to only show the settings here: https://i.imgur.com/I5Aa74A.png
    2. Then instead of the custom text widget, please try the regular search widget: https://i.imgur.com/MuOIOv3.png

    That should basically yield the same result when using the settings shortcode.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.