Search Title Only

This topic contains 3 replies, has 2 voices, and was last updated by Ernest Marcinko Ernest Marcinko 6 years ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #8916
    Leon Viveros
    Leon Viveros
    Participant

    I want the search to only look at the titles of the books and show results only where the search query matches the word or/and the title of one of the woo commerce products.

    Also it seems to run slow, can you give me some pointers with regards to this?

    #8921
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    I’m assuming the book title is the same as the woocommerce product title? In that case, on the General Options -> Sources panel make sure to only have the Search in title option enabled, and the Search in content, Search in excerpt, Search in terms options are disabled: https://i.imgur.com/v1OhIbp.png

    Please check this chapter in the documentation on how to improve search performance. It’s especially valuable if you are running on a shared, managed host.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #8962
    Leon Viveros
    Leon Viveros
    Participant

    This is the current configuration and these are the results.

    Having tried both index table and regular engine.

    Settings preferences as you indicated above.

    If I search for exiled, there is only one title that has the word exiled in the db, yet its bringing up other titles. try it out

    Same with Red Or Green, there is only one title, when you do the search it brings back other results.

    Thank you for the prompt answer and help on this issue.

    http://www.indiancountrybooks.com

    #8963
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    I’ve checked the configuration and I have found the problem(s):

    1. The main reason: The redirections are enabled, but not the override, so the default woocommerce search was effective: https://i.imgur.com/Km2jd9E.png
    I have enabled that option for you.

    2. As default, only the “All” product category is selected, while it has only 4 items.

    Please note that you still won’t see any results if you type in “exiled” because all the categories are de-selected of which the result is part of. You either need to move every item to the “All” category, or select at least one of the categories (Culture, History, Native American, Political Science for this particular result) before searching.

    Everything else seems to be configured correctly. I’ve also re-created the index table to make sure it’s not that, but it was fine as well.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.