Search turns up no results (2)

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Search turns up no results (2)

This topic contains 9 replies, has 2 voices, and was last updated by  robborkow 4 years ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #1625

    robborkow
    Participant

    Updated this with the ftp info – I couldn't add it to the original thread:

    I’m getting a “no results” message when I try searching my multi-site, set up as a main site/sub-directory: warwickpost.com and warwickpost.com/listings.

    I’ve selected both sites in the options, selected search categories, which should bring up all the entries categorized “restaurants” but it’s not returning any results for either site – when there is at least one post on Warwickpost.com and several on the listings page.

    #1628

    Ernest Marcinko
    Keymaster

    Hi!

    Thank you for the proper description and the login details!
    It was a javascript bug possibly caused by another plugin, which I could not allocate. Fortunately I made some changes in the search code, now it should work fine 🙂

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #1629

    Ernest Marcinko
    Keymaster

    Hi!

    Thank you for the proper description and the login details!
    It was a javascript bug possibly caused by another plugin, which I could not allocate. Fortunately I made some changes in the search code, now it should work fine 🙂

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #1632

    robborkow
    Participant

    Thanks – I do get results now, but results from the listings page are still not turning up. For instance, “restaurants” is not returning listings tagged and categorized as restaurants on warwickpost.com/listings. Also, the search widget isn't available on the listing page – and the documentation appears to say that it should be available there on install.

    It seems like I'm missing something.

    #1633

    robborkow
    Participant

    Additionally: It seems the search is turning up the same results regardless of search term. For instance, “restaurants” and “police and fire” turn up the same results, neither one of which include posts tagged, categorized or using those terms.

    #1634

    Ernest Marcinko
    Keymaster

    Hi!

    I'm just leaving the office, but I've noticed 2 things, which should be fixed and will solve some of the issues.

    1. I've noticed 2 instances of the same search module on the opening page. You should remove one of them, or create another search instance and replace one with that if you want to use 2 searches on the main page.

    2. There are number of javascript errors through page loading on my console, which also should be fixed. They are not affecting the search in any ways, however many plugins use the built-in jQuery and one simple error can make them unfunctional. I've attached a screenshot of this.

    I will take a deeper look at the problem tomorrow morning again. No worries, everything will work fine after a bit of fine tuning.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #1635

    Ernest Marcinko
    Keymaster

    Forgot the screenshot.

    Attachments:
    You can't view files in this topic.
    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #1637

    robborkow
    Participant

    Thank you very much, Ernest! Have a pleasant evening!

    #1639

    Ernest Marcinko
    Keymaster

    Hi!

    I've made some progress with the search, however I cannot access the listings site. I'm also afraid that the listings are not custom post types nor anything similar, which makes them impossible to search 🙁 If you could make a login for me to the listings site I might be able to see if there is anything I can do to make it work.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #1644

    robborkow
    Participant

    OK – I'll open up a new ticket with that info now.

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.