some problems with the plugin…

Home Forums Product Support Forums Ajax Search Pro for WordPress Support some problems with the plugin…

This topic contains 5 replies, has 2 voices, and was last updated by

3 years, 4 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #19109


    You can find the search form in the blue part (les vignerons) and click on “accés aux filtres”.
    I have some configuration problems on the front end. During a search, if we click on the cross to close the result window, the check box of the form remains checked, can’t we reset the form to zero?

    In mobile display I would like the result window block to be positioned under the search field and not under the forms, is this possible?

    And finally, can we remove the scroll bar on the search fields?

    Thank you for your help, very cordially

    • This topic was modified 3 years, 4 months ago by  Yannick.


    Hello, have you forgotten me?



    I am very sorry, I must have missed your ticket by accident.

    The filters only reset if the page is re-loaded. The close icon on the pop-up screen only changes the visibility of the pop-up. The only possibility would be to attach an event to the clos icon to reload the page, but I don’t know if that would be a convenient solution.

    Mobile device visibility
    Try enabling this option here:
    It will force the results box to hover just below the search bar, for better visibility for the results.

    Scroll bar
    By increasing this height, the scroll bar will not be triggered:

    I hope this helps!

    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)



    Hello, thank you for your answer.

    for the first question, I was talking about the cross that appears in the search field, not the cross that closes the popup (my English is bad, sorry!). It’s annoying that you can’t reset the search fields other than by reloading the page…

    For the mobile, if I take your proposal, I no longer have the search fields… and if next to the box, I choose visible setting, the search fields appear on the home page…

    For the scroll bar, I put high values at max height, but I still have the scrollbar no matter what value I put.
    Thank you for your help!



    The scrollbar script is malfunctioning, because of a custom CSS, that is added to the header, it looks like:

    div.asp_w.ajaxsearchpro .mCSBap_container{
        margin-top: -5px !important;
        margin-bottom: -5px !important;
        margin-right: 15px !important;
        margin-left: 15px !important;

    Instead of this, try using padding, that should work fine:

    div.asp_w.ajaxsearchpro .mCSBap_container{
        padding-top: -5px !important;
        padding-bottom: -5px !important;
        padding-right: 15px !important;
        padding-left: 15px !important;

    That might do the trick with the scroll bars.

    Mobile device visibility
    I see what you mean now. It was a simple z-index issue only. I have increased the results box z-index on the back-end, now it should display over the settings correctly on mobile:

    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)



    Hello, thanks for your help, it’s good for the scrollbars! On the other hand, for mobiles, if you tick a box, the result appears over the fields and you can’t choose a second field for example, is it possible to disable the automatic result for mobiles?

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.