Special characters and .com in search

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Special characters and .com in search

This topic contains 5 replies, has 2 voices, and was last updated by

7 years ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #3361



    I had to disable the search plug in 🙁
    People need to search shops on our site. But the plug in gives wrong results.

    When you search articles like “Bol.com” with the plug in:
    – it searches wrong, not like the normal search, it gives (I think) results on all .com searches

    “V&D” search:
    – the search gives also wrong results. seems not to convert the & sign.

    Please can you fix this to make my new year great 😉




    Could you please pass more information on this? The title/content search is UTF-8 and special character ready, so it must be something else.

    – What type of content are your searching? (post, page, custom post type, category, taxonomy term, buddypress users etc..)
    – Which fields contain the searched phrases? (title, content, excerpt, custom field)
    – Is the search working correctly in other cases?

    Also, could you please provide temporary admin/ftp access for me to see exactly the origin of the issue is? Otherwise it’s extremely hard to tell. In addition please also make a test page (only with the search shortcode), hidden from the public where I can test the plugin.

    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)



    It’s just the title in normal posts. The plug in is now active on this test page: http://promo-code.nl/testing/
    Please search things like Bol.com and V&D and compare with the small search in the black header.

    You can already test the bug here on your tickets system.
    Just search for my topic title with .com


    Indeed, you are right.

    Misteriously it was not related to the characters. If you try the topic search, it will work now. The problem was, that the search was unexpectedly excluding some of the categories. But I don’t think that’s the issue there with you, because you get unexpected results.

    Are you by any chance using fulltext search? Fulltext mysql database queries are highly sensitive to these special characters and often they percieve them as regular expression operators. If so, then please turn off the fulltext search on the Fulltext search settings submenu: https://i.imgur.com/bmGk51p.png

    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)



    OK that solved all things! thx for the perfect support! 5 stars

    I have also a request… I don’t want to show the categories in the setting button. But I want to have a button to search normal posts or other types.


    Sure, you can have those settings of course. If you check the “Frontend Search Settings -> General” panel, you can choose which custom post types you want to show. Also make sure you have the “Show search settings switch on the frontend?” enabled on the same panel as well.

    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.