Stop pages from being indexed in the search results

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Stop pages from being indexed in the search results

This topic contains 1 reply, has 2 voices, and was last updated by  Ernest Marcinko 3 years, 7 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #4212

    Adam Judish
    Participant

    Hello,

    I use the WordPress SEO plugin by Yoast and have set certain pages to no index, no follow but when I use the Ajax search to look for something, the pages are still being shown in the results.

    How do I stop these pages from being found by Ajax?

    They are for subscribers only and shouldn't be able to be accessed by searching for them.

    Thanks!

    #4218

    Ernest Marcinko
    Keymaster

    Hi!

    In your case I think the optimal solution would be to create 2 different search instances, one for visitors, one for subs.

    On the advanced options panel within the search settings, there is a field on the almost bottom of the page where you can add post/page IDs to exclude from the search results. If you don't have like hundreds of restricted pages, then you can enter the page ids to restrict from the visitors.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.