Suggested keywords no working properly

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Suggested keywords no working properly

This topic contains 22 replies, has 2 voices, and was last updated by Ernest Marcinko Ernest Marcinko 6 years, 11 months ago.

Viewing 15 posts - 1 through 15 (of 23 total)
  • Author
    Posts
  • #5621
    Pedro Carrillo
    Pedro Carrillo
    Participant

    Hi,
    I have the Suggested keywords set up with post tags. It’s been working ok, but at some point one of them stoped showing results, then anotherone, at the moment 3 of the suggested keywords are not working, the rest are working fine.
    I haven’t made any changes on taxonomies, however I’ve tried cleaning the cache, changing the ajax options, etc. Nothing works.
    Thanks,

    #5622
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    Just checked the site, the server gives a very weird response with dozens of different cookies, that should not be there, also there is a repetitive no-cache pragma printed all over the response header.

    I don’t think it’s related to the search plugin, as it does not manipulate the response headers in any way. It migth not be a plugin related issue at all. I’m thinking of a lower level server-side cache like varnish or something similar, I honestly don’t know, it’s impossible to tell based on the response only.

    What you can try, is to turn off the custom ajax handler, and use the WordPress default on the Compatibility Options submenu: https://i.imgur.com/0PWzHSc.png

    I have seen similar issues with some security and cache plugins, which sometimes block ajax requests as false positives, causing no response. If that’s the case, then the suggestion above should help.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #5624
    Pedro Carrillo
    Pedro Carrillo
    Participant

    Thanks Ernest,

    I’ve tried the turning off the custom ajax handler as you suggest, but it doesn’t work.
    Any other suggestion?
    Thanks,

    #5625
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    I see a different error now, which might bring us closer to the solution:

    http://quiquealien.com/wp-admin/admin-ajax.php is missing, error 404

    That is not good at all, that’s an internal wordpress file. Please check if that file exists on your server in that directory, it’s responsible for all WordPress ajax requests on the front-end and back-end.

    If the file is not missing, then there must be a malfunctioning .htaccess rule in your .htaccess file, which redirects all requests to the admin-ajax.php file to the default 404 error page.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #5626
    Pedro Carrillo
    Pedro Carrillo
    Participant

    Thanks Ernest,
    The file http://quiquealien.com/wp-admin/admin-ajax.php does exist. This is my .htaccess it seems to be ok.
    Thanks,

    #5627
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    I didn’t get the .htaccess file, but If the .htaccess is ok, then it’s either a plugin redirecting the request, or the Apache vconf files are causing it.

    The url http://quiquealien.com/wp-admin/admin-ajax.php should return a “0” if you open it in the browser, but it does not, it’s redirected to a 404 error page.

    Check for example wordpress.org ajax url: https://wordpress.org/wp-admin/admin-ajax.php
    or the ajax url of this site: https://wp-dreams.com/wp-admin/admin-ajax.php

    You can try deactivating a few plugins (mainly cache plugins) to see if any of them is causing this. The 404 problem is unfortunately not related to Ajax Search Pro, so I honestly don’t know what might exactly cause it.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #5662
    Pedro Carrillo
    Pedro Carrillo
    Participant

    Sorted!
    You were right, is nothing to do with the plugin, it was because the server was executing PHP 5.3 it’s been changed to 5.5 and now works fine.
    Many thanks Ernest,

    #5710
    Pedro Carrillo
    Pedro Carrillo
    Participant

    Hi Ernest,
    Sorry to bother you again with this issue, but the problem came back, now the keyword “Arquitectura” is not working, the rest is ok.
    According to my server, there is a Javascript error on that metakey (attachment)
    Regards,

    Attachments:
    You must be logged in to view attached files.
    #5724
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    It indicates that the ajax response body is empty, so there might be an error there, but it’s not displayed. Can you turn on the error reporting in the wp-config.php file? I will try it again, maybe it will display something informative with the error reporting.

    Once again I see the extremely long cache control headers. This very long string is sent to the server:

    no-store, no-cache, must-revalidate, post-check=0, pre-check=0, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache, no-cache

    The search plugin does not modify the ajax header. This might not be related to the issue at all, but it’s worth investigating where it’s coming from. Something, somehow is adding this extra overhead to the ajax header.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #5733
    Pedro Carrillo
    Pedro Carrillo
    Participant

    Hi Ernest,
    According to my server, there is some incompatibility between your plugin and wpml-media, wpml-string-translation y wpml-translation-management disabling these plugins the ajax search works ok.
    Original mesege from my server:
    “”Hemos realizado pruebas en su web observando que deshabilitando los plugins wpml-media, wpml-string-translation y wpml-translation-management cargan perfectamente todas las búsquedas de las metaetiquetas.
    Es posible que exista alguna incompatibilidad entre ellos y el plugin ajax search pro.

    Por tanto no encontramos incompatibilidad entre el plugin y el servidor. Sería tan amable de ponerse en contacto con el proveedor de dicho plugin y que realice un debug de la situación con los 3 plugins que le indicamos deshabilitados? “”

    Regards,

    #5773
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Have you managed to fix the problem? I just typed in the keyword “Arquitectura” and it’s working. I’m interested on how you solved this problem, if it was a bug in the search I could fix it.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #5778
    Pedro Carrillo
    Pedro Carrillo
    Participant

    Hi Ernest,

    No, I haven´t fix it at all.
    When you type in “arquitectura” only shows 1 post which contains that word in the title, but there are 82 posts taged as “arquitectura”.
    At the moment I have 8 plugins deactivated, if I activate any of them, the metakey “Escapadas” will stop working. If I activate all plugins, some more keywords will stop working.

    Regards,

    #5779
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    There is definitely an error message somewhere, but it’s either supressed, or turned off somewhere. The ajax request returns a completely emtpy response, so the search looses the control at some point for some reason. In case of no results there should be something in the response body, so there must be an error somewhere.

    Have you found out why is the no-cache header added so many times?

    The only option I can see here is for me to check your back-end and debug the code through FTP. There is no error message, nor an indication of errors so the only option is debugging the code directly. Could you please provide temporary back-end and FTP access to the test server so I can debug through the code? You can upload them in a .txt file, it’s not accessible to anyone but me and you.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #5781
    Pedro Carrillo
    Pedro Carrillo
    Participant

    Hi Ernest,

    I attach the credentials for wordpress and FTP

    Many thanks,

    Attachments:
    You must be logged in to view attached files.
    #5796
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    I’m not able to access the wp-admin dashboard and the FTP credentials are not working. Can you please check the account permissions and the FTP account credentials?

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 15 posts - 1 through 15 (of 23 total)

You must be logged in to reply to this topic.