taxonomy not working

This topic contains 8 replies, has 2 voices, and was last updated by somuch77 somuch77 6 years, 11 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #5862
    somuch77
    somuch77
    Participant

    Hi, I tried to exclude some tags and change relevancy based on tags, but I can’t find it. I don’t know if there’s something wrong here, usually I don’t need this, but now my post count increased and now need to setting to better relevancy.
    I’ve tried version 1.2 and 1.1, both of them not working on this part
    http://prntscr.com/8er74u
    http://prntscr.com/8er7cz

    Am I doing it wrong or this is a bug? thanks for your reply

    #5933
    somuch77
    somuch77
    Participant

    bump

    #5939
    somuch77
    somuch77
    Participant

    bumpy road

    #5949
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    If you mean post tags, then it’s unfortunately not possible yet. Every other taxonomy term should work, except for tags.

    It’s a long story why it’s not implemented yet, but I’m working on it 🙂

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #5956
    somuch77
    somuch77
    Participant

    sure is short answer for a long awaited one

    i think unless you’re doing this RPP coding for hobby, you should get a partner, i can’t imagine you handle this, tons of coding. i have premium theme, sahifa, i think even they have less coding files than yours. you should create your own wp theme, it could be awesome.

    #5957
    somuch77
    somuch77
    Participant

    hi, i just create 2 custom taxonomies, lets say “Include” and “Exclude”. on “Include”, i have “A” and “B”, on “Exclude” i have “one”

    3 posts for trial (around 100 posts total)
    post 1 = “A” “B” category car
    post 2 = “B” “one” category motor
    post 3 = “B” “one” category motor

    on post relevancy i put “Include” as match taxonomy, match taxonomy for tags and categories are off
    on advanced – exclude terms, i put “one” on it

    result on post 1 i have post 2 and post 3 on RPP, so taxonomies match have higher priority than exclude terms?

    when i exclude category motor, on post 1 there is NO post 2 and post 3, so exclude category have higher priority?

    UPDATE
    on relevancy, tags match on, taxonomy match off
    on advanced exclude term on, i put “one”, not working, post 1 and post 2 still shows up
    conclusion from my side, exclude term not working. let me know if i can do something about it.

    • This reply was modified 6 years, 11 months ago by somuch77 somuch77.
    • This reply was modified 6 years, 11 months ago by somuch77 somuch77.
    • This reply was modified 6 years, 11 months ago by somuch77 somuch77.
    #5967
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Thanks!

    I will try to recreate this exact scenario now and see how the query looks like. It definitely seems something is not right with the exclusions. A post from 1 matching exclusion should not show up, no matter what.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #5970
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    Found the problem. It was an issue with the taxonomy term exclusion part. I’ve fixed it along with other things, and a new version was uploaded to codecanyon just minutes ago.

    It should be available in 48 hours (it usually takes them 12), you should get an email notification once it’s ready for download.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #5978
    somuch77
    somuch77
    Participant

    awesome! you rock dude!

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.