'The' search bug

This topic contains 4 replies, has 2 voices, and was last updated by

 
Participant
6 years, 11 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #3944

    Participant

    Hi there,

    We have a bug on our site where any post/page title that is prefixed with ‘The’ does not appear in search results if you type the title exactly.

    For instance, we have a page for a film called ‘The Servant’ (you can find it in Actor > Filmography). If you search for ‘Servant’ then it appears in the search results, but if you search for ‘The Servant’ it does not.

    Any ideas?

    Thanks,

    Oliver

    #3945

    Hi!

    – Does the title actually contain the word “the”, or is it prefixed within the theme layout?
    – Does this happen if you type in the search keyword in full lowercase?
    – Is the fulltext search mode activated? (Fulltext search options submenu) In some cases the database ignores some words or word combinations in fulltext mode.
    – What is the Keyword logic set to? https://i.imgur.com/Q9SGAGa.png
    If it’s “And with exact word matches”, then the “the” part is actually not stored in the database, or at least this is what I suspect. Or it’s an unknown bug yet.
    – Is the “Show exact matches only” option turned on or off? What happens if you type partial phrase, like “he servant” or “the serv”?

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #3946

    Participant

    Thanks for the quick reply.

    1) Yes, the title actually contains the word ‘The’. The full title of the post is ‘The Servant (1963)’
    2) Case doesn’t matter, it bugs with both.
    3) Fulltext search is off and unused.
    4) Keyword logic is the default – AND.
    5) Show exact matches is off. Partially typing the second word (without the ‘the’) does return results also, for instance typing ‘serv’ returns it in the results.

    Regards,

    Oliver

    #3947

    No problem at all.

    Would you please try to change the keyword logic to “OR”? That is actually the default value. It should solve the issue.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #4013

    Participant

    Sorry for the belated reply, i’ve been away.

    Strange. That wasn’t a value i have ever touched. Oh well!

    Still no change though. It still doesn’t show.

    Regards,

    Oliver

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.