translating using polylang pro

Home Forums Product Support Forums Ajax Search Pro for WordPress Support translating using polylang pro

This topic contains 2 replies, has 2 voices, and was last updated by bitstorm89 bitstorm89 2 years, 4 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #27555
    bitstorm89
    bitstorm89
    Participant

    Hi there, I have tried taking the steps that you mention to translate strings using polylang but not all the strings appear. https://grid.willp.co.uk/ I have a more advanced search on that page which polylang does not pick up, any ideas? Where it says View all groups in the string translation ajax search pro is not listed. Many thanks for any help you can give on this.

    #27558
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi,

    Thank you for the details, it helped a lot!

    I needed to make a few debug changes to the plugin code to resolve this. Looks like the “pll_register_string” function was not working correctly from the polylang API, there was probably a change of some sort that I am not aware of.

    It is not perfect, but the strings should appear now. For each search instance there should be separate strings now – the search ID is in a parenthesis (where applies).

    I will have to debug this issue on our local servers to see what exactly is going on, and apply a fix to a later release.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #27561
    bitstorm89
    bitstorm89
    Participant

    Thanks Ernest much appreciated!

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.