Using URL to pre-populate search options

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Using URL to pre-populate search options

This topic contains 22 replies, has 2 voices, and was last updated by Ernest Marcinko Ernest Marcinko 1 month, 2 weeks ago.

Viewing 8 posts - 16 through 23 (of 23 total)
  • Author
    Posts
  • #39205
    vincentb
    vincentb
    Participant

    Thank you Ernest for troubleshooting this!! Definitely an improvement: browsing to the search page gives the right results (including paging) when initially rendered! However after a quick test I found some variations that are still showing bugs:

    1- Only the first page of results is matching the expected results when refreshing the page or navigating directly to the URL from the previous search (e.g., navigate to /search5, refresh — or copy URL, open new tab, paste URL).
    2- Toggling options between all / appreciation=2 / appreciation=3 (special test value), produces inconsistent results (sometimes the wrong results are shown after the first page of results, sometimes the number of results is incorrect).

    I have modified slightly the same test case to use again Infinite Scrolling, to ease testing.

    I think we are on the right track. Would you please investigate the other 2 potential bugs and let me know?

    • This reply was modified 2 months, 3 weeks ago by vincentb . Reason: added more precise description of the bugs
    #39206
    vincentb
    vincentb
    Participant
    You cannot access this content.
    #39210
    Ernest Marcinko
    Ernest Marcinko
    Keymaster
    You cannot access this content. Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #39215
    vincentb
    vincentb
    Participant
    You cannot access this content.
    #39463
    vincentb
    vincentb
    Participant
    You cannot access this content.
    #39480
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi,

    I got your messages, sorry for the long wait!

    Unfortunately I can’t do live sessions, but I am more than happy to help as much as I can. I think I might be able to replicate the issue on our local server, so I will investigate on both ends.

    I don’t think I have the FTP access anymore, I did not save the password from the one time link. I delete everything after some time, so no customer data is at risk. Can you please send it again?

    In the meantime I will look into this on a local installation.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #39592
    vincentb
    vincentb
    Participant
    You cannot access this content.
    #39620
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Thank you!

    Unfortuantely I have not found the issue yet. I will keep you updated.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 8 posts - 16 through 23 (of 23 total)

You must be logged in to reply to this topic.