Viewport Issues (Search Result Height)

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Viewport Issues (Search Result Height)

This topic contains 9 replies, has 2 voices, and was last updated by

 
Participant
6 years, 6 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #5093

    Participant

    I am having trouble with the Viewport for Search Results. I cannot seem to get the height of the viewport to display without a Scrollbar. I am using Vertical Results. The only adjustment I seem to have is the single item height. If I adjust to auto, the search results are barely visible. I have tried the compatibility options and disabling plugins but nothing seems to work. I have also tried the block version and it has issues.

    Need urgent help with this as I have a client who is expecting the website complete in 3 days.

    I appreciate any assistance.

    #5094

    Hi!

    I’m guessing you are using some kind of grouping of results? In that case there is actually a known issue, which is going to be patched in the upcoming version.

    Until then I have a very quick fix for the issue.

    Open up the \wp-content\plugins\ajax-search-pro\includes\views\results\group-header.php file on the server.

    Go to the last line (21), which should be this:

    <div class="asp_group_header"><?php echo $group_name; ?></div>

    Change that line to:

    <div class="asp_group_header group"><?php echo $group_name; ?></div>

    That should solve the issue 🙂

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #5102

    Participant

    Hi Ernest,

    Thanks for your prompt reply. It seems to have fixed the layout slightly but I am still unable to get rid of the viewport.

    For example if you type in ‘adm’ in the search box there are 3 results, 2 under Course, 1 under Industry. No matter what I seem to do, the viewport is always too small for the results and a scroll bar is used.

    I can confirm this is an issue with Grouping, as when it is turned off, no scrollbar is shown.

    Thanks for your help in advance.

    Regards,
    Aaron

    #5109

    I see, but I don’t know why. I have this exact change on my test environment and it “unfortunately” works.

    Can you provide temporary back-end and ftp access to a test server where this issue occurs? I suspect that either a 3rd party CSS or javascript is conflicting, but I’m not sure.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #5123

    Participant

    That would be great. Thanks Ernest. Please find below WordPress and FTP logins:

    ** Moved for security reasons **

    Thanks for your help.

    Kind Regards,
    Aaron

    • This reply was modified 6 years, 7 months ago by  Ernest Marcinko. Reason: moved details to a txt file for security reasons
    Attachments:
    You must be logged in to view attached files.
    #5124

    Participant

    Forgot this:

    Here is the development URL: http://pathcareers.staging.wpengine.com/

    Thanks

    #5136

    Hi!

    I was able to log in. First I had to re-install the plugin, it indicated a missing file when searching – it might have happened when transfering live to staging.

    Your configuration looks all right to me so I was about to check the javascript files, but I’m not able to use the ftp details. I’ve tried the url you provided and the 119.9.56.187 IP address as well with both FTP and SFTP, ports 22 and 2222 as well, but I get a timeout. Is it a different url or IP? Should I use FTP or SFTP?

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #5147

    Participant

    Hi Ernest,

    Apologies for not expanding on the server details. I should have provided more details. Please see the attached txt file for more details.

    Thank you,
    Aaron

    Attachments:
    You must be logged in to view attached files.
    #5157

    Thank you Aaron!

    Finally, I have found the issue. The height calculation was only taking 1 group element height into account even if there were more. I’ve corrected the javascript, so it should work fine now.

    You will have to use this staging copy of ajax search pro to preserve the change. Also, on the production environment please open up the Compatibility Settings submenu and change the Javascript source to “Non minified”: https://i.imgur.com/kmYjL3j.png

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #5162

    Participant

    Hi Ernest,

    Absolutely perfect. Thanks so much for your help. It has worked really well.

    Thanks for your patience and persistence in solving this issue.

    Cheers,
    Aaron

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.