Warning message

This topic contains 5 replies, has 2 voices, and was last updated by Ernest Marcinko Ernest Marcinko 5 years, 3 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #12535
    shiftdev
    shiftdev
    Participant

    I have installed the plugin but I am seeing the following message at the top of the admin screens:

    Warning: Invalid argument supplied for foreach() in /nfs/c06/h08/mnt/88756/domains/schellbray.com/html/WP2017/wp-content/plugins/ajax-search-pro/includes/classes/ajax/class-asp-deletecache.php on line 46

    Attachments:
    You must be logged in to view attached files.
    #12538
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    Thank you very much for the proper details. I’ve looked up the reported lines in the error message, it’s a tiny mistake, happens only under very rare circumstances. You can safely ignore this warning, it will not cause any issues.

    If you want me to fix it directly on your server, then feel free to add temporary FTP details to your ticket, and I will do it of course. I will however patch this in the upcoming release as well.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #12544
    shiftdev
    shiftdev
    Participant

    Thanks! I do not have FTP access and since it will not cause issues, I will wait for your next update. However, I am having trouble with Result Ordering. I have followed the instructions in the documentation, but can not get the proper result. I am trying to get attorney profiles (portfolio post type) to appear first in search results, but now matter how I work the Ordering settings, they do not. I have also changed the Priority numbers for all of those posts. For example, from the home page, if you search for Edward Chaney, a blog post appears before his profile page in the results. Are you able to look at this and see where the problem is?

    Thank you.
    David.

    #12550
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    Everything looks okay on the plugin configuration page, except one thing. The search override was not enabled, thus the plugin only did a redirection to the results page, leaving the original wordpress results. I’ve changed it on the General Options -> Logic & Behavior panel: https://i.imgur.com/nGroNdj.png

    Now you should start seeing attorney results on top of the results list, on the results page.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #12554
    shiftdev
    shiftdev
    Participant

    Thank you for your help! The support you provide for your plugin is outstanding.

    Thanks.
    David.

    #12558
    Ernest Marcinko
    Ernest Marcinko
    Keymaster
    You cannot access this content. Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.