words in the search field

This topic contains 13 replies, has 2 voices, and was last updated by onir onir 6 years, 9 months ago.

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #6299
    onir
    onir
    Participant

    How can I prevent the plugin from showing premade words into the search box.

    for example in the attached image there is “jack” and then greyed out “in the box”.
    Jack is part of the web site content, but “in the box” is not.
    Its possible to block this words from appearing?

    thanks

    Attachments:
    You must be logged in to view attached files.
    #6302
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    It’s the search autocomplete function and you can turn it off entirely on the Autocomplete & Suggestions -> Autocomplete options panel: https://i.imgur.com/aSrvXKQ.png

    For more information, you can read the chapter related in the documentation: https://wpdreams.gitbooks.io/ajax-search-pro-documentation/content/autoc_keyword/autocomplete.html

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #6305
    onir
    onir
    Participant

    Hi

    thank you for the fast response.
    I also tried to catch the words only from post’s titles (excluding google).
    But the feature doesnt seem to work properly.

    Attachments:
    You must be logged in to view attached files.
    #6307
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    “But the feature doesnt seem to work properly.”

    Can you please explain the problem in more details?

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #6308
    onir
    onir
    Participant

    Sure.

    The behaviour doesn’t change. In other words the script goes on searching words from google.
    So in the above example the result is still Jack “in the box”.
    Having excluded google from the autocomplete fields that shouldn’t happen.
    If I am right indeed, with that setting I am supposed to see only the words coming from “Post titles”.

    #6309
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    But the screenshot you attached shows the Keyword suggestions panel and not the autocomplete, those are 2 different things.

    If you siwtch to the Autocomplete panel, the google should be still there.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #6310
    onir
    onir
    Participant

    I had set both the panels in the same way.

    #6311
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Make sure you clear your site page cache for the changes to apply.

    In case that does not work, then can you please provide temporary admin and FTP access to check on the issue? I’m not able to replicate it on my test servers. You can add access by editing your first post in this thread, or by uploading a .txt file with the details. Both methods are safe.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #6315
    onir
    onir
    Participant

    -> http://manual.nohaliahq.wpengine.com/wp-admin/
    waqas
    Qc5(1qWps)LNB1%(uFlUyYjg

    Server Address: 23.253.71.23
    Port Number: 2222
    nohaliahq-waqas
    Qc5(1qWps)LNB1%(uFlUyYjg

    #6361
    onir
    onir
    Participant

    Hi

    have you had some time to login and check the problem?

    thanks

    #6373
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    Yes, thank you for the details.

    It was a yet unknown issue with Multisite installation. I’ve made a minor change to the code, it should display post titles now.

    I’m going to look for a better fix for the upcoming update of course.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #6375
    onir
    onir
    Participant

    hi

    ok thank you.
    Just to be sure I understood it all, you changed the plugin code on my server, and you expect to update that on a future release.

    Best

    #6376
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Yes, I’ve changed the plugin code a tiny bit, to have it fixed. The upcoming update will have a fix already included so you wont loose the change in case you update 🙂

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #6377
    onir
    onir
    Participant

    ok thank you 🙂

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.