WPML trouble after upgrade from 4.7 to 4.8.1

Home Forums Product Support Forums Ajax Search Pro for WordPress Support WPML trouble after upgrade from 4.7 to 4.8.1

This topic contains 2 replies, has 2 voices, and was last updated by Ernest Marcinko Ernest Marcinko 6 years, 11 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #7832
    hpATasp
    hpATasp
    Participant

    Hi folks,
    I’m using WP + WPML, the website is in German and in English language. Now I upgraded Ajax Search Pro from 4.7 to 4.8.1.
    Search in german language: Works as expected, gives me german result pages with links to those pages.
    Search in english language: Gives me english result pages, but the links don’t refer to the english pages, but to their german counterparts.
    Example: Search for ‘imprint’, result is page ‘Imprint’, should link to /en/imprint/, but links to /de/impressum/.
    Any hints
    Regards
    Helmut

    #7834
    hpATasp
    hpATasp
    Participant

    ok. It seems as if I found the problem.
    Compatibility Settings -> Use the custom Ajax handler -> Off
    solved the problem.

    #7843
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi Helmut,

    I’m glad you could solve it. I will note this as a possible issue, and perhaps add a notification to warn users to not use the custom ajax handler when WPML is active, if no other solution is possible.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 3 posts - 1 through 3 (of 3 total)

The topic ‘WPML trouble after upgrade from 4.7 to 4.8.1’ is closed to new replies.