Issues with scroll, highlighter and multilanguage

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Issues with scroll, highlighter and multilanguage

This topic contains 19 replies, has 2 voices, and was last updated by

 
Keymaster
1 year ago.

Viewing 15 posts - 1 through 15 (of 20 total)
  • Author
    Posts
  • #30715

    Participant

    Hi, I still got an issue with scrolling to key word and highlighter, all setting ok on to get this option, you can see on attachements images.

    Also got an issue where we are on the french version and search with an english key words, the result appear in both language but if I clic on the english result that redirect me on the image and not on the page in english. You can try beef in the french version to see this issue.

    Thanks

    Attachments:
    You must be logged in to view attached files.
    #30730

    Hi,

    I just checked, but the script reports a plugin version 8 releases before the current one (4.19 vs 4.20.2), please update the plugin to the latest release via the plugin manager. If the plugin is up to date, then clear all layers of cache. Also, please never revert plugin versions from newer to older ones, if you did, then in that case I recommend using a plugin wipe, and then reinstalling the plugin.

    I tried to log-in to the back-end to check, but the account has no access to Ajax Search Pro options: https://i.imgur.com/4K9qc65.png

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #30766

    Participant
    You cannot access this content.
    #30770

    Hi,

    The highlighter did not work, because it was not enable in the first place: https://i.imgur.com/e7t6b3m.png
    I enabled, now it seems to work okay.

    The translations didn’t work, the WPML compatibility was also turned off, I re-enabled it: https://i.imgur.com/eRygQEb.png

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #30779

    Participant
    You cannot access this content.
    #30781

    Is the WPML compatibility enabled on that search bar? It is different from the one on the french site.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #30782

    Participant

    Yes I turn it ON and still go wrong. The problem is, the search return this slug /product/beef but it suppose to return /en/product/beef.

    #30783

    You had the custom ajax handler enabled: https://i.imgur.com/LpD7Eid.png
    I turned it off, it should be okay now. You can find all WPML compatibility tweaks here.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #30785

    Participant

    All right Thank you very much, that an excelente plugin with a lot oh settings. Now we are All set 🙂

    Have a nice day !

    #30790
    You cannot access this content. Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #30792

    Participant

    Just another question, my customer want to can serch english content on the franch site. Exempl search “Beef” in french site and redirect to english page, is that possible?

    #30793

    Yes, if you disable the WPML compatibility, then it will search all languages.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #30810

    Participant

    I Ernest, I disable it, but we have the same trouble like before, the search bar find the page but not with the good URL, he find /product/beef and not /en/product/beef.

    Is another option I have to check or uncheck?

    #30830

    I tried to save the WPML options to clear their plugin cache, and I think it helped. Can you check?

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #30978

    Participant

    Ok super that work, can you tell me how you or where you save the WPML options to clear plugin cache ?
    Because now the site is online on nepco.ca, I have to do the same on this site, or you can login here with the same assets.

    Thanks 🙂
    Have a nice year!

Viewing 15 posts - 1 through 15 (of 20 total)

You must be logged in to reply to this topic.