Search – No results displayed

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Search – No results displayed

This topic contains 10 replies, has 2 voices, and was last updated by heraulc2 heraulc2 7 years, 9 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #1893
    heraulc2
    heraulc2
    Participant

    Hi, We are trying to use your plugin to search within our FAQ posts but unfortunately, when searching for terms, the search plugin returns no results at all. Could you please help us understand what the problem is?
    Many thanks,
    Celine

    • This topic was modified 8 years ago by heraulc2 heraulc2.
    #1898
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    Can you link me to a page, where the search is enabled, perhaps with phrases you are trying to search for?

    My first guess would be a visual editor conflict, but I can’t confirm that yet. Some visual editors store the post data outside the posts table, which makes it impossible to look for, but I highly doubt that this is the case now.

    It’s more likely, that the ajax request gets stuck somwhere, I might need an temporary ftp account to confirm that, and to do a quick debugging on the search code.

    I looked at the configuration, it looks fine, so it’s not that.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #1916
    heraulc2
    heraulc2
    Participant

    Hi Ernest,

    Thank you for your message. I am just replying now because I did not receive an email for the follow up, while I’ve clicked that option on (maybe something you should look into).

    Regardless, I’d be happy to give you FTP access. How can I provide you with the ftp info privately?

    Thank you,
    Celine

    #1917
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    It has been a server outage at our host, maybe that’s the reason. You should get a notification of this reply.

    You can edit your first post, there are private fields for ftp access (only visible for me and you). If the forum won’t let you edit the first post, then you can upload a txt file zipped with details. File uploads in your topics are also only visible for you and me only.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #1919
    heraulc2
    heraulc2
    Participant

    Hi,

    I have updated the initial post. Thanks for your help.
    Right now, the plugin is active on this page http://i-cthru.com/question/ and searches within this page http://i-cthru.com/faq and the related FAQ posts.

    Best,
    Celine

    #1933
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    Thank you for the details, I couldn’t get to fix the issue yet. It’s a javascript problem. As soon as I get to my workstation I will fix it. (in 24 hours tops)

    Thank you for the patience!

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #1948
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    The ftp account was not working (I could only see an empty directory), but I managed to make some changes via the plugin editor. I’m not sure if it will work or not, because the javascript files are cached and I couldn’t find any tool to refresh the cache.

    After refreshing the cache you should be able to see the results list now.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #1970
    heraulc2
    heraulc2
    Participant

    Hi,

    Thanks for your help. It now seems to be working. If you upgrade your plugin, do I need to be aware of any changes you made to our website so the plugin will keep on working?

    Many thanks,
    Celine

    • This reply was modified 7 years, 12 months ago by heraulc2 heraulc2.
    #2472
    heraulc2
    heraulc2
    Participant

    Hi Ernesto,

    You helped me with this issue in the past, but I don’t know how you fixed it. We know have the plugin on this page http://i-cthru.com/faq/ and the search shows no results, while it still works on this one http://i-cthru.com/question/
    How can we fix this? Last time you mentioned it was a javascript issue.

    Let me know. Thank you,
    Celine

    #2484
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    The problem is that the same search instance is on that page more than once – which is not supported by the plugin version that you are using.

    I suggest you to update to the newest version (by downloading the package again from codecanyon).

    The steps for safe updating you can find here, please read them carefully: http://wp-dreams.com/knowledge-base/updating-from-older-versions/

    After upgrading the problem should disappear.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #2489
    heraulc2
    heraulc2
    Participant

    Thank you for the very quick reply

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.