Knowledge Base

Updating from older versions

in Ajax Search Pro Troubleshooting Tags: how topluginsearchupdateupgrade

If you have an older version of the search (2.4 and below), then some extra steps are required for the safest possible update. For version 3 the search was re-factored completely and it is not fully compatible with older versions – mostly to preserve speed and to save unnecessary code and site performance.

Steps for updating
  • Deactivate and delete the plugin via the plugin manager.
  • Upload and install the newest version of the search plugin
  • Go through the Analytics Integration, Fulltext Search Settings, Cache Settings, Compatibility settings menus and hit the save button on each page.
  • Go through all of the search instances you created and hit the save button without changing any values
What to do if the search stops working after update?

In this case the only option is to delete the existing search instances and create new ones.