Search plugin scrambled in IE, works in Chrome

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Search plugin scrambled in IE, works in Chrome

This topic contains 26 replies, has 2 voices, and was last updated by Tobias Tobias 8 years, 7 months ago.

Viewing 15 posts - 1 through 15 (of 27 total)
  • Author
    Posts
  • #860
    Tobias
    Tobias
    Participant

    The plugin works fine when viewed in Chrome, but misses icons and functionality in IE. Is that a known limitation?

    #861
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    I just checked the website you give in ie9 and 10 and it looked fine to me. Can you perhaps add screenshots of the issue? Which ie version are you using?

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #862
    Tobias
    Tobias
    Participant

    I am using IE11, and I can see the problem here on a number of machines. The inner search box textbox seems to be displaced, and the search buttons are not visible. Can you double-check?

    #863
    Tobias
    Tobias
    Participant

    I just discovered that the search menu now is always visible and appears in the lower left corner of the site – again just in IE11.

    #864
    Tobias
    Tobias
    Participant

    And I should add that your site including the search box on it will display correctly in IE11. Puzzled…

    #865
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Ok, I think I found the source of the problem. There is a css property on the style1.css line 514 “content:…” and it’s somehow bugged, thus the rest of the styling is not loading after that line. As far as I recall I fixed this in the 2.0 version alpha, I will send you copy to try it out in a few minutes.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #867
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Here is the 2.0 version alpha.

    Please delete the old search from the plugins before installing, along with the searches you have already configured (it’s unfortunately not compatible backwards)

    You should see tons of new features on the administrator area. It’s a bit harder to configure, but it should work better.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #869
    Tobias
    Tobias
    Participant

    thank you, will try it asap… πŸ™‚

    #870
    Tobias
    Tobias
    Participant

    your new options look promising! However, after I installed the update, I now get a warning on all pages:
    Warning: session_start() [function.session-start]: Cannot send session cache limiter – headers already sent (output started at /home/powert21/public_html/wp-content/plugins/ajax-search-pro/ajax-search-pro.php:21) in /home/powert21/public_html/wp-content/themes/parallelus-razor/framework/utilities/email-functions.php on line 3

    #871
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Oh I know why. I downloaded from test site with filezilla and it placed an extra blank line there. Here you go, this should work now.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #873
    Tobias
    Tobias
    Participant

    Thank you. The error is gone now.

    However, the search widget does not respond to anything – no click, no text enter ?!

    it does display correctly on IE11 πŸ™‚ however it is not doing anything.

    #874
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    I think it’s only because it’s cached from the first bad version I sent you.
    If you have cloudflare or something similar cdn, try to clear all caches. Hitting ctrl+shift+R solved it to me on firefox, but I think the cache content is still there. Let me know if it helped!

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #875
    Tobias
    Tobias
    Participant

    it must be a caching issue however cloudflare did not change it. Maybe browser cache. For some reason, I now see two different search box designs, one in chrome and another one in IE11. I hope this will resolve over time when caches expire… 😎 Thanks for your lightning fast responses, it is a pleasure working with you!

    #876
    Tobias
    Tobias
    Participant

    oh, and your new version rocks!!! Forgot to mention. What a cool widget!

    #877
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    No problem at all!

    Let me know if you find anything strange, this version is under heavy testing and not finished yet πŸ™‚

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 15 posts - 1 through 15 (of 27 total)

You must be logged in to reply to this topic.