Search settings shortcode prints duplicated filters

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Search settings shortcode prints duplicated filters

This topic contains 4 replies, has 2 voices, and was last updated by

 
Participant
2 years, 1 month ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #24993

    Participant

    Hello, I managed to make appear the search settings on the catalog sidebar of my store, however, the shortcut is showing duplicated search settings as shown in the screenshot attached. I also attach the settings I have right now, I checked the widget settings and there’s only 1 text widget with the shortcode of the search settings.

    I tried to turn on the option “Show search settings switch on the frontend?” and when I click the switch button it loads only 1 search settings widget correctly, however when it is disabled and “Set the search settings to visible by default?” is ON then the search settings are shown twice.

    Attachments:
    You must be logged in to view attached files.
    #25001

    Hi,

    It prints twice, if the same search shortcode is used twice on the same page. I think using my previous suggestion in the other topic will resolve this as well.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #25006

    Participant

    But I need to display my search bar on a different location than my search filters, my search bar is in the header and the search filters need to show up at the sidebar of my store, so Im using a shortcode to display the searchbar and another shortcode for just the search settings…

    #25018

    Hi,

    I see what the duplication is caused now. There is a carbon copy of the search for the mobile menu or the mobile version of the site. Because there are two copies of the same search, there will be two copies of the settings as well.

    The simplest bypass I can think of, is by hiding the second copy of settings programatically:

    .asp_sb_1_2,
    .asp_s_1_2 {
       display: none !important;
    }

    That will get by that issue.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #25030

    Participant

    It worked! nice thank you very much!

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.