Search wheel is spinnig but nothing happens

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Search wheel is spinnig but nothing happens

This topic contains 5 replies, has 2 voices, and was last updated by bellyfeel bellyfeel 7 years ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #4949
    bellyfeel
    bellyfeel
    Participant

    Hello!
    Your plug-in seems really great, thanks for your great work!
    Unfortunately I can’t make it do what I wish to. Basically I would like it to search only in my portfolio titles. I put all the settings in plug-in settings and then I realised that I doesn’t suggest me titles (no autocompleting – it was working only when I had Google suggestions enabled) and even if I put a word into a search box and hit Enter the wheel icon is spinning but nothing happens.

    I went through your article: https://wp-dreams.com/knowledge-base/when-i-type-in-something-the-search-wheel-is-spinning-but-nothing-happens-why/
    and I did everything that you asked for – disabling plug-ins and changing the theme into WordPress default. I looked through topic from your support pages and found tips about saving cache options but it also didn’t work.

    In the past I also had some problems with Ajax on the same website and I disabled it in the theme options. At the moment it’s enabled.

    Error-log in Ajax Search pro files was empty but I’m sending you error-log file from wp-admin of website version 5.

    I would really appreciate your help. Please let me know if you need any other details.

    Thank you!
    Sylwia

    Attachments:
    You must be logged in to view attached files.
    #4951
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    Thank you for the detailed description and the error logs, it helped me a lot.

    The problem was an unsupported function call, which was introduced in plugin version 4. It seems like that in rare cases some wordpress installs does not have this enabled. I’ve made a tiny modification on the search code, it should work now.

    This code part is going to be replaced in the upcoming version, so you don’t have to worry about it anymore.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #4952
    bellyfeel
    bellyfeel
    Participant

    Wow!

    Your help really made it work, thank you very much.
    At the beginning of my message to you I also wrote that I can’t make autocomplete work properly. It’s not showing me portfolio titles. Portfolio comes from the Gridstack Theme that is not default WordPress theme.

    But it seems like that your plug-in searches a phrase “pro” which was ment to be “production” and in results it’s showing me everything that contains “pro”. Just this autocomplete thing is not working.

    Thank you,
    Sylwia

    #4953
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    Sorry, I missed that. It was the same issue in that file as the first. It should work now.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #4954
    bellyfeel
    bellyfeel
    Participant

    Great, it looks really good.
    I would like to ask a question about WPML in the same ticket if it’s not a problem.

    I have wpml compability switched on. I need to see reasults for a current language only but it finds all 4 languages I translate it to.

    Do you know what can cause this problem?

    Thank you.
    Sylwia

    #4975
    bellyfeel
    bellyfeel
    Participant

    I think we have sorted this out via the settings – thanks!

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.