plug in errors. please help!

Home Forums Product Support Forums Related Posts Pro for WordPress Support plug in errors. please help!

This topic contains 40 replies, has 2 voices, and was last updated by

 
Participant
5 years, 2 months ago.

Viewing 15 posts - 16 through 30 (of 41 total)
  • Author
    Posts
  • #2741

    Participant

    unfortunately it did it again…

    try this post to see it live:

    http://www.blueverticalstudio.com/kumagai-house-by-hiroshi-kuno-associates/

    thanks!

    #2742

    Hi!

    That url is currently working for me. This is very strange. How is it possible, that sometimes it’s working, sometimes it’s not. I mean, the related posts plugin outputs the same exact html for the same post – so I don’t understand how can it get corrupted.

    Anyways I did a googling on this thing, and if I’m correct then you are using the WP Fastest cache plugin. I’ve found a support thread with a problem very similar to yours with a different plugin: https://wordpress.org/support/topic/html-is-corrupted?replies=6

    I’ve downloaded the plugin and examined the code, and my best guess is that the html checking function is failing or it’s buggy in some cases – that would explain why a page on your site is working sometimes, then it fails on other times. Anyways, in my opinion the best thing to do is to bypass that function with a minor modification on their code. Since they are aware of this issue I think they will solve it sometime soon.

    Open up the wp-content/plugins/wp-fastest-cache/inc/cache.php file and go to line 137, where you should see this function:

    public function checkHtml($buffer){
    	if(preg_match('/< \/html>/si', $buffer) && preg_match('/< \/body>/si', $buffer)){
    		return false;
    	}
    
    	return true;
    }
    

    replace it with the following:

    public function checkHtml($buffer){
      return false;
    }
    

    This will bypass the html check for now, until they fix the regular expressions in this function. After this change, clear the cache and the pages should start showing up correctly.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #2745

    Participant

    hello.

    the only problem is it still does it w/o the cache plugin turned on.

    try this and see if it does it for you – live:

    http://www.blueverticalstudio.com/light-point-systems-by-stephan-tillmans/

    thanks!

    #2746

    Okay. Then I think you should turn on error reporting for a while, to see if there is anything informative.

    You can do that by editing the wp-config.php file on your server, arount line 82 you should see this:

    define('WP_DEBUG', false);
    

    change it temporary to:

    define('WP_DEBUG', true);
    

    then let’s hope that some error messages will pop up, that would be the best.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #2747

    Participant

    ok.

    will the site still be usable? i have some other wok to do.

    thanks again!

    #2748

    Participant

    errors are showing up.

    let me know when to change it back.

    thanks! 😀

    #2749

    Okays, you can switch it back, I got it.

    It looks like the site is running out of memory even before it reaches the related posts plugin.

    The error messages on the top are fine, those are some notices only, the issue is the following:

    Warning: Invalid argument supplied for foreach() in /hermes/bosnaweb06a/b1072/ipg.blueverticalstudio1/ezine/wp-content/plugins/wp-slimstat/wp-slimstat.php on line 683 Warning: Invalid argument supplied for foreach() in /hermes/bosnaweb06a/b1072/ipg.blueverticalstudio1/ezine/wp-content/plugins/wp-slimstat/wp-slimstat.php on line 683 Fatal error: Allowed memory size of 41943040 bytes exhausted (tried to allocate 2857795 bytes) in /hermes/bosnaweb06a/b1072/ipg.blueverticalstudio1/ezine/wp-includes/wp-db.php on line 104
    

    So while the slimstat plugin is reached the memory runs out. I’m not sure what is the memory limit on the server but you should definitely check that. Anything below 512MB is critically low for a wordpress installation with several plugins.

    You can try to increase the memory limit programatically by adding the following lines to the wp-config.php file, but it might not work, if it’s restricted on server side:

    ini_set('memory_limit', '1024M');
    
    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #2750

    Participant

    i’ll check with my host.

    would it change if i simply turned that plugin off?

    thanks for all of your help!

    i will definitely recommend your plugin 😀

    #2751

    If you turn that off it might help, or maybe the memory runs out later on rendering, it’s really hard to tell. If the limit is set to a low value, then it won’t help much. It would be a much better solution to increase the memory to 1024MB or at least 512 if possible. Under heavy traffic it’s a good thing to have 😀

    I’m running this site and all the demo sites + test sites + another site on a 2048MB VPN, that’s like 10 wordpress installs and it’s doing all right. At most I had like 800MB consumed, but it was under very heavy traffic spike. So I definitely recommend increasing the memory to at least 1024MB, that will cover a single wordpress install for enormous traffic spikes with a proper caching.

    No problem, feel free to ask me anything related the plugin. I usually answer within 24 hours.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #2752

    Participant

    terrific!

    thanks again for your time and info! 😀

    #2753

    Participant

    can i ask you a quick question since this ticket is open? 🙂

    is it possible to display a related post instance that uses my portfolio links and thumbnails?

    i was hoping to get it to show portfolio items on my index page like i show blog posts –

    see here (scroll down:

    http://www.blueverticalstudio.com

    gracias!

    #2754

    I think so. If the protfolio is a custom post type (which I guess it is).

    You can select it on the content options panel. Here is it in the documentation: http://wp-relatedpostspro.demo.wp-dreams.com/docs/#content_options

    Turn off the “Return posts” and “Return pages” options and drag the portfolio (or whatever it’s called) custom post type from the right column to the left.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #2755

    Participant

    very cool!
    i love the minimal way it displays 😀
    i’ll give it a shot…
    thanks!

    #2756

    Participant

    when i create a new instance does it copy the one i have or create a new one one with the original settings?

    do the settings need to be changed to the changes we made?

    thanks!

    #2757

    When you create a new one, it uses the default settings, it does not copy the other one. You need to configure that one as well.

    In the upcoming version I will add an option to make a copy, it had been requested a few times before.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 15 posts - 16 through 30 (of 41 total)

You must be logged in to reply to this topic.