Reply To: Search box drop-down


Ernest Marcinko


Can you please make sure you have the following configuration:
It forces to have at least one term match per taxonomy, for both taxonomies. So at least one tag AND one category has to match.

The shortcode I've pasted there is to replace the one you have, I'm sorry I forgot to mention that. So instead of the widget you have, use this shortcode in the 'shortcode' widget.

The z-index fix will not work with that shortcode however – as it displays the elements as blocks, and block (static positioned) element z-indexes are not used.

In short:
Solution 1: If you prefer to use the search widget, then adjust the z-indexes like so:
..then make sure to clear all the site cache, including the assets, pages and reload the page a few times by hitting CTRL + SHIFT + R, as browsers tend to very heavily cache the stylesheets. If it is still displayed incorrectly, then try this custom CSS:

.searchsettings {
   z-index: 2 !important;

If this still does not have any effect, then the page is still heavily cached, as this code has to work 100%.

Solution 2: ..or instead of the search widget, use this shortcode in the shortcode widget:

[wd_asp elements='search,settings,results' ratio='100%,100%,100%' id=1]

This one is a bit harder to predict, but it should create a search, results and settings box in this order. Whenever the settings box is clicked, it opens below the search bar, and whenever the results are displayed, they display below the search bar, but above the settings box. This is not a hovering layout though.

Unfortunately I can't do phone or screenshare support, as there are many tickets I need to answer, and I cannot predict when I get to each one. Sometimes it's minutes, other times it could take over 12 hours. Sorry about that.

I hope this helps though!

Ernest Marcinko

If you like my products, don't forget to rate them on codecanyon :)