Reply To: Search is very slow


Ernest Marcinko


Sorry about the ftp/admin details, it was my fault – I was fixing something on the server and forgot to activate that code part back.

I'm currently testing, right now it's all right in terms of speed – response under 2-3 seconds.

Your database is all right, it's small.

The problem might have been the shared web hosting. Most of shared web hosts use process throttling, meaning if too many php processes are running at the same time it halts the server for a brief amount of time (usually 30 seconds). The limit used to be around 10-20 processes, which is enough for cached traffic usually. But if you are actively testing your site, enabling/disabling plugins, changing configurations, then this limit is passed in few seconds, and the PHP processor is halted. WordPress with some plugins and active testing on the backend uses lots of resources.

Another possibility would be memory, but the search plugin peaks at 0.5 MB of memory, so I think we can rule that out.

I might be wrong though, but the nature of the issue indicates process throttling.

On the search url: It's not actually changing the url (because it can't unfortunately), but it gives you an option to change it if you already have a custom search url.
To have a custom search url, you probably have to make changes to the .htaccess file. I've found a tutorial, that might help you out:
After making the changes in the .htaccess file, you can go back to the search settings, and change the search url field accordingly.

I know it's a bit confusing, but I wish there was a better way around this.

Ernest Marcinko

If you like my products, don't forget to rate them on codecanyon :)