Reply To: Autocomplete

#8747

Ernest Marcinko
Keymaster

Hi!

From what I can see, I highly suggest disabling the Trigger search when typing? option, as described within the 1 high priority point in the guideline I linked previously.

I'm guessing the server you are running is on a shared environment, or running a decent amount of plugins (or both). Shared hosts have a parallel execution limit, which delays each request triggered by typing. Disabling the triggering on typing prevents to send repetitive requests until the user hits enter, or the search icon, saving tons of resources.

All the demo sites and this site together run on a very cheap 10$/month VPS droplet on Digial Ocean servers – but since it's unmanaged, it does not have an execution or shared memory limit like most shared hosting plans. This allows a much faster, and unmetered parallel execution. On the downside however, the host does not help, and is not responsible for setting up the environment.

I can also suggest two other caching methods, which work flawlessly for me personally:
PHP opcode cache – this is enabled on all php 5.5+ installations. I highly recommend updating to PHP 5.5 if you are not using it yet. In case of shared hosts, you might have to contact your server administrator to help you with that.
Memcached with W3TC – it's nother fantastic caching method, for Database queries. PHP-memcache is installed on most servers. If you have SSH access, you can install this on your server, or ask the server administrator to do it for you.

I hope this helps!

Best,
Ernest Marcinko

If you like my products, don't forget to rate them on codecanyon :)