Reply To: Ajax Search Pro not turning up results for all sites

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Ajax Search Pro not turning up results for all sites Reply To: Ajax Search Pro not turning up results for all sites

#1688

Ernest Marcinko
Keymaster

Yes it does, because the listings site was/is created in the multisite installation, but it's virtually not the same as the listings site that is actually there.

Managing a multisite needs a bit of practice 🙂 Some plugins and themes are not compatible with multisite, so you should first check if the plugins you want to use on your listings site are compatible with multisite installations.

In my opionion what you need to do is:
1. Backup everything – all the sites, files, databases everything.
2. Delete the public_html/listings directory completely
3. From what I can see from the listings config file the listings wordpress uses the “robborko_wor7” database, you should delete that as well (but first backup of course)
4. Now, log in back to your main site at warwickpost.com/wp-admin and open up the network admin sites panel options
5. Delete the listings site from the sites list – it should be still there
6. Now add a new site – listings
7. That's it, no files are needed, nothing, if you then go to warwickpost.com/listings url you should see the new wordpress site.

Virtually you will have now a main site and a listings site + a network administrator panel. Some plugins need to be installed through the network administrator panel (such as ajax search pro) some of them not.

It's a bit hard to get used to it, but as long as you have your backup files it's going to be all right – you can restore everything if something goes wrong.

Here is a longer reading about this: https://codex.wordpress.org/Multisite_Network_Administration

I hope this will help you a bit with the multisite madness 🙂

Best,
Ernest Marcinko

If you like my products, don't forget to rate them on codecanyon :)