Reply To: The results take a seriously long time, over 15 seconds

Home Forums Product Support Forums Ajax Search Pro for WordPress Support The results take a seriously long time, over 15 seconds Reply To: The results take a seriously long time, over 15 seconds

#2503

Ernest Marcinko
Keymaster

The problem with custom fields is, that wordpress stores them in a separate table, and if you have for example 10 custom fields for every post, then the initial search base becomes 10×25000 = 250 000. The more custom fields you have, the bigger it grows.

There is definitely something wrong with the configuration, as the “what does the fox say” should come up as first, even for exact matches. Did you turn off fulltext search? The MyIsam database engine has a so called “stop words” definition file, which excludes words below length 4 and some very common words like “what”, “do”, “does” and a couple thousand more.. So no matter what you type, the database just ignores it in fulltext mode. Here is how you can turn it off: http://wp-dreams.com/knowledge-base/no-results-for-some-keywords/

Also, when trying new configurations make sure, that the search cache is disabled. (it's disabled by default)

Can you provide temporary admin and ftp details so I can check your configuration and do a debugging on the search code if neccessary? You can do this safely by editing your first post in this thread.

Best,
Ernest Marcinko

If you like my products, don't forget to rate them on codecanyon :)