The results take a seriously long time, over 15 seconds

Home Forums Product Support Forums Ajax Search Pro for WordPress Support The results take a seriously long time, over 15 seconds

This topic contains 8 replies, has 2 voices, and was last updated by

 
Participant
7 years, 4 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #2478

    Participant

    When researching your plugin, your FAQ stated that it would only run slowly if the site had over 100,000 posts. Well our site has 25,000 and the plugin is running so slowly it isn’t really functional. The wait time was 15 seconds on one computer and over 20 on another. Can you please tell me how to fix this?

    • This topic was modified 7 years, 4 months ago by  videkat.
    #2479

    Participant

    Update: The wait time is actually 25 seconds. I disabled all my plugins and my theme, which didn’t shorten the time. I changed the javascript source to Non minified which shortened the wait time from 25 to 20 seconds. Please get back to me as soon as you can. Thanks.

    #2480

    Participant

    update: The slowness has to do with including custom fields. Can this be fixed with coding?

    #2481

    Hi!

    If you deselect custom fields, then the search speed is normal? (3-5 seconds)
    What is the size of your databse? (I mean number of posts, products etc..)

    In case of bigger database (more than 10-20000 records) the search speed highly depends on the server speed and the configuration. There are a few things you can try first.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #2501

    Participant

    Thanks for your response. I did as you advised, but adding custom fields slows it down so it doesn’t work.

    I really want your plugin to work for me, but I think I have too many issues with it. Can you please help me with the following…

    1. If I search “What does the fox say” it doesn’t come up in the search. When I check “exact matches only” it still doesn’t come up. I have many videos with these exact words in the title and they don’t show up. How do I get this to show up in the search?

    2. When I search “Numa Numa” it shows up at the bottom of the results. I’ve tried orderby date asc and desc but neither work. I turned on/off relevance and everything but to no avail. How do I orderby data?

    3. Is there any way to orderyby a numerical custom field?

    Thanks.

    #2503

    The problem with custom fields is, that wordpress stores them in a separate table, and if you have for example 10 custom fields for every post, then the initial search base becomes 10×25000 = 250 000. The more custom fields you have, the bigger it grows.

    There is definitely something wrong with the configuration, as the “what does the fox say” should come up as first, even for exact matches. Did you turn off fulltext search? The MyIsam database engine has a so called “stop words” definition file, which excludes words below length 4 and some very common words like “what”, “do”, “does” and a couple thousand more.. So no matter what you type, the database just ignores it in fulltext mode. Here is how you can turn it off: http://wp-dreams.com/knowledge-base/no-results-for-some-keywords/

    Also, when trying new configurations make sure, that the search cache is disabled. (it’s disabled by default)

    Can you provide temporary admin and ftp details so I can check your configuration and do a debugging on the search code if neccessary? You can do this safely by editing your first post in this thread.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #2529

    Participant

    I appreciate your quick response, but, unfortunately, I can’t give admin and ftp details. I changed all the settings per your suggestions, but the plugin doesn’t work for our site. Not only are the custom fields an issue, but whenever I go into the plugin’s settings in the dashboard it shuts down my server making the website inaccessible for a few minutes. Since I can’t use the plugin, please refund me for the purchase as soon as possible.

    #2530

    Hi!

    Unfortunately I’m not responsible for refunds, you will need to contact envato market for that via their support center. I don’t know if they can refund you once after the product was downloaded and used, but you should try of course.

    I would love to help you, there must be something else conflicting as well, the administrator interface is not resource heavy at all – once we had tested it on a site with half a million posts on a local server with woocommerce and went through without issues.

    I have tried the built in search on your website as well, it takes around 20 seconds it to load the results page – which means that something is clearly wrong, because the built in wordpress search is very simple and highly optimized. I’m not sure if it’s the high number of data, or plugin conflict or a database server inconsistency or perhaps low cpu power, but you should definitely look into that, because some web crawler bots like to go through random search results and it could easily overload your server. (it happened to me unfortunately)

    Also I don’t know what type of hosting/server are you using, but this high amounts of data and server load might require a VPN with at least 8 cores and 4gb of memory. Shared hostings tend to shut down websites with high CPU usage – it happened to me with bluehost, and site5 as well and I had to move to a much expensive VPN plan.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #2532

    Participant

    Thanks for the tips Ernest. I contacted evato for a refund. Like I said I really wanted your plugin to work, but it isn’t functional for me.

    The search on my site right now is using a plugin that is searching my tags which takes 20 seconds. When I remove the plugin it takes about 5 seconds. And what you mentioned about the hosting is something to consider, but for now I have to try something else.

    Thanks again.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.