Reply To: And logic not working correctly

#4714

Ernest Marcinko
Keymaster

Hi!

There are two explanations I can see here:

1. Either one of the selected fields (title, content, excerpt etc..) has both words (or parts of these words) “nature” and “animals” in it. I'm suspecting the post content, which is usually longer than the title or other fields.

2. The plugin is functioning in fulltext mode. There is a known bug, where in some cases the plugin uses the fulltext mode even though it's deactivated. In fulltext mode is no such thing as search logic, as it's a natural matching database algorithm.
To get rid off this, go to the Fulltext search Settings submenu and make sure the Use fulltext search when possible option is turned OFF (https://i.imgur.com/IYO5eUx.png). Then save the settings even if you haven't changed anything to make sure the values are synced to the database.

If you see an error message like “MyIsam tables are disabled, fulltext search not available!” when going to the fulltext options page, then the fulltext search definitely not the issue.

Best,
Ernest Marcinko

If you like my products, don't forget to rate them on codecanyon :)