Reply To: Many issues with Ajax Search Pro


Ernest Marcinko

Finally I'm able to get to the login screen. I was always getting an under construction message, it must had been some aggressive caching or something.

1. I'm not sure if I get it right, but I tried the post and page search function on the back-end:
To me these look all right. Let me know if this is what you meant.

2. I selected:

Exact matches only
Search in title
Search in content
Search in posts
Search in pages

I just tried searching for “francis” and I got a good amount of results.
Then I tried “sfl” got these:
Then I tried “francis brassard” without Search in content, because I saw there a post with his name in it, and I got it as result:
Then I tried again “francis brassard” with the Search in content enabled:

Based on this it looks to me that it's working correctly. Does the problem occur on another specific example?

Also, I turned off the attachment search to test these options, I guess you only want to search in posts and pages.

– It was a CSS bug. The vertical options color was applied there, so I changed it to transparent as it should have been by default.
– It is not possible to change the spacing, it's adjusted by the isotope script. Now there is a visible spacing, since the backround is finally transparent.
– The tick color is inherited from the default theme layout to match, the only way of changind that is to use custom CSS, like so:

.searchsettings .option label:after {
border: 3px solid #00FF00 !important;

Change the code color in the code above to your liking and add the code to the search instance options Theme Options -> Custom CSS panel.

4. It's most likely theme related bug, or some javascript files are not loaded every time correctly. The results are presented as simple links to click on, so there is no way of any interference with the styling.

Let me know if you need anything more 🙂

Ernest Marcinko

If you like my products, don't forget to rate them on codecanyon :)