Ajax Error

This topic contains 10 replies, has 2 voices, and was last updated by

 
Keymaster
1 year, 2 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #29842

    Participant

    Hello,
    I’m getting an error on mobile only it seems, and only some of the time. I’ve contacted the host (Go Daddy) and they’re no help and told me to contact the plugin developer. I’ve attached a screenshot of the error.

    I’ve disabled all of the plugins, gone to a default theme and I’m still getting the error. Do you have anything you can suggest? I will give you login credentials if required. Please send response to [email protected]. Thank you.

    Attachments:
    You must be logged in to view attached files.
    #29849

    Hi,

    Thank you for the details, I was able to replicate the issue.

    I stringly suspect that this is something on the server side, as the problem is not possible to replicate 100% of the time, it happens randomly sometimes on the same phrases, then not, then again, then not.. This is definitely not a programmatical error in the plugin itself, as it would be possible to replicate all of the time with the same parameters.

    Do you happen to know if there is any object cache, or some sort of database cache active in your hosting package, on the server level? The requests are coming back with an “OK” response, so the code executes, runs and somehow there is nothing in it. I have seen previously this exact same issue with a PHP object cache enabled.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #29875

    Participant

    Hello,
    I was able to turn off all caching on the site. This is on a Go Daddy Managed WordPress plan. Do you have any other suggestions? Thanks!

    #29882

    Memory limit can also cause issues like that. Check the memory limit in the PHP configuration, and if possible increase it to 512MB. If you are using a lot of plugins/cache etc.. then WordPress might be running out of memory.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #29925

    Participant

    I gave the site 512M memory limit and I’m still getting the issue. Can I create an account for you to log into the site and take a look? If so, what email address should I send it to?

    #29931

    Sure! Can you please do an FTP as well as back-end access? I would like to go through the code to see if there is any point the issue replicates.
    You can copy/paste the details here and mark your reply as private, or edit your initial post and fill in the fields.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #29958

    Participant
    You cannot access this content.
    #29964

    Thank you!

    I maybe found something, but it is unfortunately completely unrelated to the plugin. If I open the wordpress core ajax handler file, then it should always print a ‘0’ character to the browser output. In your case however, if I keep refreshing the page a few times, I get nothing: https://i.imgur.com/CHsiQlX.png
    This of course happens even if our plugin is disabled.

    That is why the plugin reports an empty response message, as something is clearing the ajax output. I checked the PHP configuration, and the only thing that I think could cause this is the memcached PHP module. It is very rare to see memcached enabled, that is why I noticed. I recommend trying to uninstall that module via SSH to see if it makes any difference.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #29969

    Participant

    Thank you very much for the detailed response.

    I talked to the customer, and they want to move this site to a new host. I have this plugin on another site and do not have this same issue. I will do this in the next few days and let you know if I still have the issue. Have a great day!

    #30018

    Participant

    I changed hosting providers and the error stopped. Thank you again for your help!

    #30020

    That is great 🙂 You are very welcome!

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.