Ajax "More Results" not loading properly

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Ajax "More Results" not loading properly

This topic contains 1 reply, has 2 voices, and was last updated by Ernest Marcinko Ernest Marcinko 5 years, 9 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #10027
    trw226
    trw226
    Participant

    Hi Ernest,

    When you set the Auto Populate to “Enabled – Latest results”, and set the results count to 10, it displays the latest 10 posts. However, when you click “More results…”, it says “No results!”, (because nothing was entered into the search bar). This does not seem right… it makes more sense to show the next 10 latest results. The “More results…” feature works fine when a term has been queried in the search bar, but it doesn’t work for the default auto populate feature…can this be tweaked or addressed with a workaround?

    Along similar lines, if a user searches for a term, but then after the first search, deletes the search term and returns to the default blank search bar, can the default auto populate results be returned upon the search bar being cleared?

    Thanks,
    Tom

    #10046
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi Tom,

    Indeed, that is a bug I didn’t know about yet. I’ve noted and will fix it for the next release. Thank you for letting me know!

    The second request, well that unfortunately is not possible without changing things in the code. The purpose of the auto populate is to trigger exclusively on initial page load. Long story short, I havent found any workaround unfortunately, that doesn’t involve changing the code.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.