Ajax Search Pro not showing result on custom post types

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Ajax Search Pro not showing result on custom post types

This topic contains 3 replies, has 2 voices, and was last updated by

 
Keymaster
1 year, 2 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #30284

    Participant

    My Ajax Search Pro is currently not showing any custom post types results. The only result that is showing is only my page.
    The weird thing is with Ajax Search Lite, it worked and when I migrate it into Ajax Search Pro it doesn’t work anymore.
    I’ve tried so many things, changing the options in compatibility such as the ajax handler and re-initialize, then using index table engine or normal engine and even playing around with the sources in general settings. No luck. The thing is, in the back end, when using the preview, the search appears, but when I use copy the shortcode and use it on my website, it doesn’t work. Thank you in advance for your help

    #30291

    Hi,

    The WPML compatibility was activated, I turned it off: https://i.imgur.com/gGQnsRE.png
    That was the only difference in configuration I could see between the Pro and the Lite versions. It should be okay now.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #30305

    Participant

    Hi there,

    thanks for pointing it out, now it works. But, what would be the long term solution for this? Because I am planning to have a multi-lingual website and planning to use polylang, its just that I haven’t gone into the stage of translating my website yet.

    Thanks in advance!

    #30309

    Once you start using polylang, and the items are assigned to a default language, and you need to display items in the current language only, then you should turn this option back on.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.