Ajax serach Pro does not work anymore

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Ajax serach Pro does not work anymore

This topic contains 5 replies, has 2 voices, and was last updated by Ernest Marcinko Ernest Marcinko 1 year, 1 month ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #42362
    Pixinfy
    Pixinfy
    Participant

    Hi guys,

    I hope this email will will you well 🙂

    I installed and activated WPRocket yesterday in order to accelerate my website.

    For some reason, Ajax Search Pro stopped working correctly yesterday…
    The search bar at the top of the website https://www.rivesaltes.fr is not correctly displayed, and the search is not working at all. Pushing the “return” key does not work either.

    Before this incident the product was really great, I changed nothing on the Ajax Search Pro settings nor on the website… I deactivated WPRocket, but it still doesn’t work…

    Thanks in advance, your help will be greatly appreciated…

    All the best,
    Jean-Ghislain

    Admin url is: https://www.rivesaltes.fr/wp-admin
    login: divilife
    pwd: %divilife_testing%

    #42363
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi Jean-Ghislain,

    Thank you very much for the details, it helps us a lot!

    On the front-end error console there are a few messages about missing files from the wp-content/cache/ folder. I suspect that the file may actually exist, but there is either an incorrec .htaccess rule or a mod_rewrite condition, which redirects the request to the 404 page. This causes the problem with the plugin too, because the files are enqueued from that cache.
    I would recommend checking if the wp-content/cache/ folder exists (the plugin reports that it does) and if there are any files within that folder. Then checking if there is no permission restriction applied. I suspect this is an issue with a mod_rewrite rule in the .htaccess folder, as the cache folder permission issues would likely been detected.

    For now, I have resolved this by changing the compatibility settings like so: https://i.imgur.com/6ujtvR3.png
    I still recommend investigating that cache folder and the .htaccess to see why it’s redirecting.

    I hope this helps!

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #42446
    Pixinfy
    Pixinfy
    Participant

    Hi Ernest,

    Thanks a lot for your reactivity and the quick fix, greatly appreciated 🙂
    Sorry for my late answer, I had a few days off 😉

    So, here is the content of .htaccess file:

    # Begin Force HTTPS
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{HTTP:X-Forwarded-Proto} !https
    RewriteCond %{HTTPS} !on
    RewriteRule ^(.*) https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
    </IfModule>
    # End Force HTTPS

    # BEGIN WordPress
    # Les directives (lignes) entre « BEGIN WordPress » et « END WordPress » sont générées
    # dynamiquement, et doivent être modifiées uniquement via les filtres WordPress.
    # Toute modification des directives situées entre ces marqueurs sera surchargée.
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteRule .* – [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    # Desactivates folders content display
    Options All -Indexes
    # Hides server infos
    ServerSignature Off
    # Protects file wp-config.php
    <files wp-config.php>
    order allow,deny
    deny from all
    </files>
    # Protects files .htaccess et .htpasswds
    <Files ~ “^.*\.([Hh][Tt][AaPp])”>
    order allow,deny
    deny from all
    satisfy all
    </Files>
    # Activates symbolic links follow
    Options +FollowSymLinks

    I don’t see incorrect .htaccess rule or a mod_rewrite condition, but I’m no expert…

    In addition, the wp-content/cache/ folder actually exists, and there is a folder “asp” inside for the plugin, with files into it (enclosed screen-1) but it may have appeared after your fix.

    For permissions applied to wp-content/cache/ please see screen-2 as I don’t know whether this is correct or not…

    Thanks,
    Jean-Ghislain

    Attachments:
    You must be logged in to view attached files.
    #42458
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Thank you!

    It looks okay to me too, but I would still recommend reverting back to the original .htaccess and testing that way.
    From the screenshot I see that this file must exist for sure: https://www.rivesaltes.fr/wp-content/cache/asp/search1.css
    Yet if you visit that URL you are greeted with a 404 page. That can only happen if the file really does not exist (but it does), or if there is a mod_rewrite rule of some sort which prevents the access, or maybe there is indeed a permission problem.

    On the screenshot I see 750 as permission, that is not correct, it should be 755 at least, otherwise nothing can access those files. Please change the permissions to 755 recursively – including the cache, cache/asp/ and all the files within. I am 99% sure that will help.

    If still no luck and the permissions are correct, then I suggest:
    – Reverting back to the original .htaccess temporarily
    – Reverting back all permalink settings temporarily
    Then testing this URL until you start to see the file contents.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #42625
    Pixinfy
    Pixinfy
    Participant

    Hi Ernest,

    Thanks for your feedback and sorry again for my late answer, quite a lot of bank holidays in May here in France 😀

    Actually you got it 100% right : recursively changing cache folder to 755 solved the issue…
    Well done 😉

    So I changed back compatibility settings to the image enclosed.
    Does it seem correct to you?

    And do you see any settings to modify in order to have more reactivity in suggested results when typing a request?

    Thanks again a lot for your top class support,
    Kind regards,
    Jean-Ghislain

    Attachments:
    You must be logged in to view attached files.
    #42628
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Great 🙂

    That looks perfect to me. I tested the search itself, and everything seems to work as it should. The server response is superb, it is below 500ms for each request, which is extremely fast. Everything seems to be all right.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.