Autocompletion and suggestion slowness and order

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Autocompletion and suggestion slowness and order

This topic contains 2 replies, has 2 voices, and was last updated by ondikoi ondikoi 5 years, 5 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #11547
    ondikoi
    ondikoi
    Participant

    Hello,

    I replaced the default search from VideoTube with your plugin, but I need to remove some shadow through CSS from old search form. Not sure if that’s from you or theme owner. Basically logo, search form and social media stuff should be on the same line or something. Please go to site URL and you will see:

    http://ondikoi.net/wpvidtube

    However my urgent concerns now are:
    1) the slowness to display the autocompletion/suggestion
    2) the order in which they are displayed. It doesn’t seems to be by date. If it’s by date, I would like the latest videos first.

    Please try doing some search and you will see what happens. Provided you admin link and credentials to help improve this.

    Thanks!

    #11553
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi,

    The shadow issue is actually caused because the row display mode is inline-block, and the plugin displays as a block by default with a 100% width, causing a shift in the inline-block layout.
    My best suggestion is to use this custom CSS to force inline-block layout on the search container, as well as smaller width and centering on the parent element:

    #header .container > .row {
    	text-align: center;
    }
    
    #header .container .asp_main_container {
    	width: 400px;
    	display: inline-block;
    	margin: 20px auto;
    }

    That’s just a suggestion, full integration might be more difficult.

    1. If you are not using google keyword suggestions, then the results are parsed from your server, so the response time is equivalent with the server performance. In case you are on a shared host or a lower package VPN, lots of data (over 5-10k records), or using high amounts of plugins, I do not recommend using the autocomplete, or rather using google keyword suggestions as the source.

    On the good news side, I’m working on an ‘instant’ feature for both search and autocomplete results, to bypass ajax search, if instant results are available.

    2. It was simply because on the General Options -> Ordering panel the order was set to the default, Relevance as primary, and date as secondary. I’ve changed them, now it will sort by date first.

    Best regards,
    Ernest Marcinko



    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #11598
    ondikoi
    ondikoi
    Participant

    Thanks for fixing the ordering issue!

    => This is good to know
    “On the good news side, I’m working on an ‘instant’ feature for both search and autocomplete results, to bypass ajax search, if instant results are available.”

    My server is a dedicated box with 8Gb of RAM and a cpu with 8cores, only running 22 activated pluigns which I think are not that many. So I think it’s a good enough server. Also I’m only searching the title.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.