Broken Search Bar Intermittently

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Broken Search Bar Intermittently

This topic contains 2 replies, has 2 voices, and was last updated by niumalta96 niumalta96 9 months, 3 weeks ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #34094
    niumalta96
    niumalta96
    Participant

    We have an intermittent issue on our site with the Ajax Search Pro search bar. It seems to for logged out users sometimes the Ajax Search Pro Bar is broken and non functional. Only this part of the site is broken the rest all works fine. Would you be able to let us know why is this happening? Maybe there are some missing assets or maybe some javascript init is not working as expected?

    Please note that this is a live environment since we did not manage to replicate the issue on staging yet. Please refrain from doing any changes without consulting us.

    Attachments:
    You must be logged in to view attached files.
    #34097
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi,

    This looks like a cache related issue to me. The search bar on the second picture is actually not the plugin search – so the cache might be serving an outdated version of the site.
    To make sure it is no a browser user agent mix-up, please turn off this option: https://i.imgur.com/Dsz45Tf.png
    After that, clear all layers of cache and it should be fine.

    I have only seen this issue once before, and then it was related to that option. Some google robot visits were cached as if real page loads and the search was not rendering to them, and that cache was served back to the users then.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #34098
    niumalta96
    niumalta96
    Participant

    Thank you for your quick reply. Maybe that is the reason why we cannot replicate on staging since no bots are accessing staging site. We have updated the setting and will run some more tests. If the issue persists will let you know.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.