Bug discovered with legacy scritps

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Bug discovered with legacy scritps

This topic contains 10 replies, has 2 voices, and was last updated by barabasis barabasis 5 months, 2 weeks ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #35748
    barabasis
    barabasis
    Participant

    While we were solving the ticket opened here “dev question” (actually we solved it), we discovered a bug with legacy script.

    We now have legacy non minified option enabled here:
    https://mistresskym.com/wp-admin/admin.php?page=asp_compatibility_settings#4

    Here is the filter page:
    https://mistresskym.com/mk/content/

    ANY other option we set, we don’t see the thumbnails anymore on the above page /content!!
    And of course this is a problem if the legacy will be deprecated soon.

    We have a customized Favorite plugins that are enabled that and that add a layer on the thumbnails: “Select Ajax Search Pro Extra” and “Custom List Manager” plugins. BUT, also if you disable those 2 plugins the problem persists, so those are not the problem here.

    Any modification have been made to the original plugin and everything is as in your original plugin.

    Pls be cautious, it’s a live website, with clients and traffic.

    #35750
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi,

    Can you try turning off the image lazy loader script here: https://i.imgur.com/qtWLFYa.png
    If there is another lazy loader type of script included, or if there was any modification to the output it may not work. I strongly suspect that is causing the issue.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #35751
    barabasis
    barabasis
    Participant

    Never turned that on… actually it always stayed OFF.
    We use wprocket, but on that page there is no lazy loading, it’s disabled…

    #35758
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    I just checked, and it is perfectly fine on my end: https://i.imgur.com/0wWYcWy.png
    If I turn that option ON, then it breaks, if I turned it OFF, then it is fine. Then it might be the modification to the output, which that script may not like.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #35772
    barabasis
    barabasis
    Participant

    ok it may be a misunderstanding Ernest.

    I never switched the option “Use the Lazy Loader jQuery script to load the images?” ON since I purchased the plugin.
    So it always have been OFF. But that’s not the problem.

    The problem is that if I switch from the “legacy non-minified” setting that I have now (and everything works fine) to “Minified (default)” I see the attached! (cleared both wprocket cache + my FF browser data-cache)

    Thanks

    Attachments:
    You must be logged in to view attached files.
    #35776
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Thank you, I indeed missunderstood you.

    I found the issue, sort of a bug, but it is more complicated. So basically, there is some sort of a script injecting some the content to the page (including the search), and the injection was not yet completed, when the scripts were loaded. The script was trying to initialize any search bars on the page, however during the execution none were present.
    The jQuery version worked almost all of the time, because that is much slower to render for the browser. On some refreshes even that did not work, when the timing was right.

    Luckily it is not a big deal, as we encountered similar behaviours with the legacy scripts a few years back, and we added this option to resolve these types of injection/late loading conflicts. It is extremely rare, but yet it can happen.

    I have turned that option on, and it should be fine now with both script sources in every case.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #35790
    barabasis
    barabasis
    Participant

    Hello,

    thanks for the explanation and to have found the problem.
    But actually if I switch to minified (default) the problem stays the same… try to switch to that yourself…

    Also, the top navigation bar just disappear with current settings, which of course is a problem.

    Pls let me know

    Attachments:
    You must be logged in to view attached files.
    #35792
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    I switched to the minified version, cleared all cahces possible, and it seems to be okay on my end: https://i.imgur.com/YFLSZHl.png
    Maybe it is only the browser cache, it can be aggressive sometimes. Can you please re-check?

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #35793
    barabasis
    barabasis
    Participant

    It’s not a matter of cache, I cleared already.

    I switched it back to non-minified cause it’s a live website and I need it to be working.

    But if you switch back to default and you try to CLICK on the pagination you will see that actually it doesn’t work… + also, as you can also see on your printscreen, the pagination on top isn’t showing, while instead is set to be shown and with legacy scripts it just work properly

    #35822
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    We just released patch 4.21.6
    Can you please update to see if that fixes that issue? There was a fix implemented to a very similar problem, and I assume that may fix this one as well.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #35824
    barabasis
    barabasis
    Participant

    Yep that one completely solved the problem.
    Thanks a lot!!

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.