Bug : Indexing problem

This topic contains 5 replies, has 2 voices, and was last updated by Manu Manu 5 years ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #13599
    Manu
    Manu
    Participant

    Hello Ernest,

    I’ve come across a new bug since i have updated WordPress 4.8 and Ajax Search pro v4.10.5.

    I’m using the following configuration :

    Index Table
    Index titles : On
    Index Content – Index Excerpt : Off
    Post types to index : A Custom Post Type
    Index Taxonomies : 2 Taxonomies for this Custom Post Type
    Index Permalink -Index post author name – Index post author bio: Off
    Post statuses to index : publish

    The issue : Since the update, each time I’m saving a post for my Custom Post Type with a status different from “publish” it is indexed on the index table. So All the pending, future, draft are indexed even if the post statuses to index is set to “publish” only.

    On the Indexing and cron options i turn off “Index new posts upon creation”, i’ve deleted the index and created a new one, the cache was emptied but it’s still indexing any post i’m creating/updating whatever the status of the post is.

    Please tell me if you need more info.

    Thank you,

    Manu

    • This topic was modified 5 years ago by Manu Manu.
    • This topic was modified 5 years ago by Manu Manu. Reason: Adding some precisions
    #13647
    Manu
    Manu
    Participant

    Hi Enernest,

    Are you able to reproduce this bug ?

    It’s quite a problem because each time i’m saving a draft CPT , it will appear in the search result.

    Thank you for your help,

    Manu

    #13765
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi Manu,

    I’m not able to re-create this bug unfortunately. The drafts are not being indexed for me, it might be a conflict or a very specific issue. I’ve tried many different configurations, but I have not found anything.

    I suggest opening a ticket with log-in details, and I will take a look at the issue directly.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #13766
    Manu
    Manu
    Participant

    Hi Ernest,

    Thank you for your answer,

    I will try to debug as soon as possible and i will let you know what i will find.

    #13778
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    I think I have found the problem, it’s related to multisite environments only.

    To fix the issue, please replace the file contens in wp-content\plugins\ajax-search-pro\includes\classes\actions\class-asp-indextable.php with this: https://gist.githubusercontent.com/anag0/25d119fb40fd1a4ea3d44b6e82822416/raw/5cb9e43bb5bae759ccf5bc10180c638c1f151095/class-asp-indextable.php

    After that, make sure to re-create the index table under the Index table options submenu. That should solve the issue permanently. I will also make sure to include this fix in the next release.

    PS: please have a back-up of everything, before making any direct changes.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #13782
    Manu
    Manu
    Participant

    It’s working 🙂

    Thank you very much for your help !

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.