Caching issue with Search Bar

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Caching issue with Search Bar

This topic contains 11 replies, has 2 voices, and was last updated by mapongamike mapongamike 5 years ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #13242
    mapongamike
    mapongamike
    Participant

    Hi Support,
    My search bar plugin ‘Ajax Search Pro’ has been experiencing a caching issue that overrides the formatting of the search bar on the website and reverts to the default WP search bar. Now this happens on certain web pages on the site. It doesn’t happen everytime on those pages. Sometimes it’s normal other times not. Here is a video screen grab showing the issue http://recordit.co/Mb71lQRhnr

    Also look at the images I attached.

    The issue normally happens on these pages (Sometimes they seem fine):
    https://www.afrolandtv.com/shows/premium-show/

    Attachments:
    You must be logged in to view attached files.
    #13245
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    I believe this is rather an issue with the cache plugin, because Ajax Search Pro cannot affect the caching method in any ways.

    I’ve logged in, cleared the cache, currently I can see the ajax search pro search bar in the header on every page I have checked. Ther might be a browser cache header as well, so it is possible that your browser serves the cached page files. It should expire within few days, but you can try reloading the page by hitting the CTRL + SHIFT + R buttons. That usually works.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #13313
    mapongamike
    mapongamike
    Participant

    Hi Ernest,

    We have tried everything with the caching pluggin. From deactiving it and trying a different pluggin ( WP Rocket) with no avail. Is there a way you could configure my settings in the puggin to not being affected by the caching? I’ve went to WP experts on codeable for assistance multiple times and they told me I have to come to you.

    I attached images of the search bar losing format as I switch from page to page on my site. Here is the link where the issue is now (The issue sometimes shows up on this page, other times not).

    https://www.afrolandtv.com/films/film-drama/

    Attachments:
    You must be logged in to view attached files.
    #13317
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi,

    There is no option, nor any way for the plugin to get exempt from the cache, only certain pages or files I believe.

    But, I might have an idea why the issue is happening here. So, I remembered that the plugin has actually a fallback code whenever someone with a very old browser visits the site. What I believe have happened is, that whenever the cache was automatically cleared, the next visitor had an old browser and the default search bar was printed instead of ajax search pro – and that layout was cached by the cache plugin.
    This would explain why only some of the pages have the default search bar visible.

    What I did, is that I disabled this fallback programatically via FTP. If I’m correct, then this should no reappear anymore, once you clear the cache.
    I will try to think of a permanent solution instead of this fallback – or maybe incorporate a switch to turn it off. I might ask a cache expert on how this should be handled in a better way for the next release.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #13318
    mapongamike
    mapongamike
    Participant

    Hi Ernest,

    Thank you so much I appreciate your time. I’ll monitor the site as we move forward. Other than that I’m very pleased with the pluggin. Looking forward to the updates.

    Cheers,

    #13387
    mapongamike
    mapongamike
    Participant

    Hi Ernest,

    The issue is back, but this time it’s on the home page and this is a very big issue because we’re losing users if the search bar isn’t functioning. I noticed the issue today and this is after the update. You previously corrected the issue before the update. Can you please look into this. I attached images for you to look at.

    Cheers,

    Michael Maponga

    Attachments:
    You must be logged in to view attached files.
    #13391
    mapongamike
    mapongamike
    Participant

    Another problem I recognized after the update is the search bar is over extended. I attached a screen shot

    Attachments:
    You must be logged in to view attached files.
    #13393
    mapongamike
    mapongamike
    Participant

    I just turned off this setting *Display the default search box on old browsers? (IE<=8)*. Screenshot attached. I remember you previously mentioning something about that.

    Attachments:
    You must be logged in to view attached files.
    #13401
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    The over extension you can fix with this custom CSS:

    div.ajaxsearchpro[id*='ajaxsearchpro'].asp_non_compact {
        min-width: 0 !important;
    }

    The other issue should disappear after you enabled Display the default search box on old browsers? (IE<=8) option. It’s the same solution as I added before the update. Make sure to clear the cache, and it should not re-appear again.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #13403
    mapongamike
    mapongamike
    Participant

    Thank you for the response. Can you please insert the CSS for me as i’m not familiar to where I should implement it at.

    Appreciate the help.

    Cheers,

    #13404
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Sure, no problem at all. I have placed it into the custom CSS section under the ajax search pro options panel: https://i.imgur.com/RBH1sBT.png
    That will stay there even after updates.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #13414
    mapongamike
    mapongamike
    Participant

    Excellent, thank you so much Ernest. I appreciate your awesome work.

    Cheers,

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.