Classes name to generic

This topic contains 2 replies, has 2 voices, and was last updated by Jacques Letesson Jacques Letesson 9 years, 2 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #4270
    Jacques Letesson
    Jacques Letesson

    Hi there,

    I love your plugin it works really great but we have a lot of problem with CSS Classes.

    Some of the classes that you use are too generic. Like .content, class that we use in the website as well.

    You should think about implementing a BEM naming convention to avoid such collision.

    Plus some of your classes are camelCase other are underscored_

    Please increase readability and flexibility of these classes.

    If you need input about that topic, please contact me.



    Ernest Marcinko
    Ernest Marcinko


    Thank you for the observation! It’s actually a work in progress. Some classes are renamed in the latest version (4.0). I didn’t do a full rework on this yet, because there were some extreme changes in the dynamic CSS generator script, and it might have caused too many bugs for testing.

    I hope for the upcoming version I’ll finally be able to replace all the remaining classes with the “asp_” prefix.

    The main priority for this version was to increase the CSS specificity and an option for the user to change compatibility levels to preserve bandwidth.
    When I first saw CSS declarations in best-seller themes like:

    #top input {
       margin: 10px;

    I was speechless. It killed the margins for the search input fields, which were placed into the top element. I’m all in for using classes only in CSS, but codes like this just makes it impossible. There is no way of overriding this with classes only (except for !important, but that’s not an option here).
    It took me a few days to put together a robust script to bypass these issues. I whish themeforest had a policy to only allow using class names in themes, or disallowing using ID’s and generics in the same line of CSS code.

    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)

    Jacques Letesson
    Jacques Letesson

    Thank you for the word of explanation Ernest!

    This is despite my previous comment, a real time-saver plugin.

    I’m sure that in the coming release it will get better and better.

    Thank you for your time and the amazing support.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.