Compatibility Ajax Broken

This topic contains 13 replies, has 2 voices, and was last updated by

 
Keymaster
6 years, 3 months ago.

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #6251

    Participant

    Hi,
    i have a problem with the custom ajax handler i read documentation and i try to speed up the search, but if i enable this option search broke and console says:

    http://www.praticando.it/wp-content/plugins/ajax-search-pro/ajax_search.php Failed to load resource: the server responded with a status of 500 (Internal Server Error)

    I do a quick debug and seems no action is passed, can you help me speed up the search?

    Thanks

    #6252

    Hi!

    It looks more like to me that the file is missing, or blocked by .htaccess or on server level.

    When I clicked on the link, it gives this error:

    Access to this resource on the server is denied!

    That means the file most likely exists, but the access is denied. This is 99% related to a .htaccess rule, as the error page is printed with a nice template. One other thing you can check is the file persmissions. It should be “644”, but you can try “755” or “775” to check if it’s permission related problem. 644 however should work without problems.

    The file is accessible correctly if it gives “-1” as the output when you click on the link. Just like the one on the demo page: http://wp-dreams.com/demo/wp-ajax-search-pro/wp-content/plugins/ajax-search-pro/ajax_search.php

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #6253

    Participant

    Hi,
    thanks for the quick response, i think you have to log in into wp-admin cause for now the site is closed, i posted you the detail already else i can unlock the whole site if i log in -1 is given correctly.

    Thanks
    Filippo

    #6254

    Also, don’t forget to turn on debug mode in the wp-config.php file. If there is a fatal error or a warning causing it, then it should print it to the response body.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #6255

    I cannot access your site, nor the admin. Looks like there is a firewall or something blocking the access.

    Please also update FTP details, if there is an error 500 there is almost no chance to debug it through the admin panel.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #6256

    Participant

    http://www.praticando.it/wp-login.php?redirect_to=http%3A%2F%2Fwww.praticando.it%2Fwp-admin%2F&reauth=1

    this link works?
    i’m opening the site
    from our part no firewall is configured

    #6257

    Participant

    Now the site is open, if you need i can give you full ftp access
    Thanks

    #6258

    I was able to log in now, but only using a proxy. Something is still blocking my address range.

    Please update the first post with FTP details as well (or you can upload a .txt file, both methods safe)

    There is no error message nor any other information in the response header, the only thing I can do is debug parts of the site and plugin code.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #6261

    Participant

    Thanks here are the ftp data.

    I also installed p3 if u need them.
    By the way the final result is can you speed up the search a bit.

    Thanks a lot

    Attachments:
    You must be logged in to view attached files.
    #6263

    Hi!

    Thanks for the details. I can only access one empty folder. Can you please check the account permissions?

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #6265

    Participant

    ok sorry try with
    [email protected]
    same password as testing

    #6268

    I have found the problem. There was an error in the grafity forms woocommerce plugin:

    Fatal error: Call to undefined function wc_is_21x() in /public_html/wp-content/plugins/woocommerce-gravityforms-product-addons/gravityforms-product-addons.php on line 113

    I’ve made a correction to that plugin code. I’ve added this line:

    if ( !function_exists( "wc_is_21x" ) ) return;

    to the wp-content/plugins/woocommerce-gravityforms-product-addons/gravityforms-product-addons.php line 113.

    For even better performance, consider lowering the active plugins number below 15. The ajax search plugin finishes within 0.1 seconds based on the performance tracker results, the rest is system and other plugin initialization and execution time.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #6270

    Participant

    Ok thanks very much!
    Any other hint to speed up the search? For you is working ok? try type visura.

    Off topic question you do also freelance job?

    #6271

    I’m afraid there is no other way. The plugin executes extremely fast, way below 0.1 seconds, so it’s optimized to the maximum already. And the P3 profiler is not going to help in this case, because ajax requests usually act very differently from a page loading process.

    It’s not possible to force other plugins to not load programatically unfortunately, so the search handler must wait for it’s turn. I’ve written an article about WP performance, you can read it if you want to, but the cause in your case is the very high number of plugins.

    You can turn on caching on the caching options panel, but it’s not going to help much, because the plugin gets the results almost immediately. The cached handler is still going to get held up by the WP loading process.

    Unfortunately I’m not doing freelance or contract jobs right now.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.