Configuration on result page problems

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Configuration on result page problems

This topic contains 6 replies, has 2 voices, and was last updated by foodmixmarketing69 foodmixmarketing69 2 years, 8 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #25614
    foodmixmarketing69
    foodmixmarketing69
    Participant

    Hi Support,
    we testing plugin on page Point-of-Sale;
    gate password: beta

    1) After setting the redirection to the search results page (after clicking the Search button), it moves to the correct page and shows the search results.
    But if I do not enter anything in the search field and choose additional options (or nothing or I will choose only additional options) and click on the “Search” button, it does not transfer to the settings page in the section with the settings of this button …

    Moves then to the main page (and does not show results, because this is not a page with results)

    2) Why it is so and how to set it to work correctly (will something be chosen from additional options, will it be entered in the search box, should it move after clicking on Search to the settings page in options)?

    3)
    What will be the easiest way, to specify a field to enter the phrase (main field of this search box) – but how to mark this field as required?

    Please advice

    #25638
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    Thank you for all the details, it helps us a lot.

    1. & 2. It looks like you have either a misconfigured .htaccess file or there is an incorrect template redirect rule defined within the theme functions (or perhaps another plugin).
    If you try to visit the search page with an empty phrase here: http://foodmixtest.net/rdf_portal/?s=
    ..then you get automatically redirected back to the main page. Unfortunately that is not the plugin doing, you can verify by temporarily disabling it.

    3. You can do two things here, one is to increase the minimum character count to trigger the search, as well as change the placeholder text to something like “Enter at least 3 characters here” or something similar.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #25644
    foodmixmarketing69
    foodmixmarketing69
    Participant

    Hi!

    Ad 1, 2. Thank you.

    Ad 3. How do you turn off live search after entering any phrases and clicking enter (instead of the Search button)?
    Live search is disabled in the plugin options…

    #25664
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi,

    3. This should help you out. Change that option to “Do nothing”.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #25665
    foodmixmarketing69
    foodmixmarketing69
    Participant

    Hi,
    you could look into the settings, how it is configured 🙂
    The “Do nothing” option is selected…

    Attachments:
    You must be logged in to view attached files.
    #25667
    Ernest Marcinko
    Ernest Marcinko
    Keymaster

    Hi!

    I think you may have found a bug, I was able to replicate this on our test environments as well. It must have been there for the past couple of releases, interestingly nobody noticed it yet for some reason, not even our automated tests.

    For now, if it is okay for you, I would suggest using the “redirect to results page” option instead. We are working on a patch release, that should be ready for tomorrow, I will make sure to fix this minor issue as well.

    Best,
    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)


    #25669
    foodmixmarketing69
    foodmixmarketing69
    Participant

    Thanks.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.