Disable scrolling and display results

Home Forums Product Support Forums Ajax Search Pro for WordPress Support Disable scrolling and display results

This topic contains 3 replies, has 2 voices, and was last updated by

2 years, 12 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #20884



    I have a lot of filters and would like to display the search settings horizontally instead of having to scroll down through all of my filters. Is there any way to disable the built-in plugin scroll and just display everything in the search settings? I tried custom CSS to display them as columns but it’s not looking very good.

    Also, I am pre-loading search results with a search phrase and notice an odd behavior. When the page loads, if I click anywhere on the page the search results disappear. I have to click back on the search box to see the results again. Any suggestions on how to fix this? Thanks.



    Sure, you can adjust both issues:

    1. On the Frontend search settings -> General Panel, change the filter box max height to ‘auto’, like so: https://i.imgur.com/7V74Cdh.png
    This should not trigger the scrolling feature, and display the full list of the filters.

    2. That is a default behavior, you can turn it off under the Layout Options -> Results Behavior panel: https://i.imgur.com/KP8eUkN.png

    These should do the trick 🙂

    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)



    Thanks so much Ernest. The second suggestion for closing the results on document click solved that problem.

    And while setting the filter boxes height to auto got rid of the scrollbar, I was looking for a way to disable that custom scrollbar completely. What I’m trying to do is display my filters in a horizontal layout so users won’t have to do any sort of vertical scrolling. I’m trying to use CSS columns and I think that could work but as soon as I set a number of columns I get the scrollbar again. I hope this makes sense.



    Oh, okay, I see what you are trying to do there. On the compatibility settings submenu, you can completely disable the scrollbar script, so it will not trigger again. Although it is still possible that the default theme scrollbar might still trigger there, using CSS columns is very tricky.

    Ernest Marcinko

    If you like my products, don't forget to rate them on codecanyon :)

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.